summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kobel2018-08-30 23:14:34 +0200
committerAlexander Kobel2018-08-30 23:14:34 +0200
commit69cfc1d80390597f9428520e38a51fd1bda0f731 (patch)
tree6ae19fd49652a4dd7d6c9a24848c5f850357abeb
downloadaur-69cfc1d80390597f9428520e38a51fd1bda0f731.tar.gz
Initial import: v1.2.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bcc94bd66d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hocr-tools
+ pkgdesc = Tools for manipulating and evaluating the hOCR format for representing multi-lingual OCR results by embedding them into HTML.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/tmbdev
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = python-pillow
+ makedepends = python-lxml
+ makedepends = python-reportlab
+ depends = python
+ source = https://github.com/tmbdev/hocr-tools/archive/v1.2.0.tar.gz
+ sha256sums = 0d3fb25e48b812afc7293b0e84bda68995ccdec627befe4607be5b79b82f508b
+
+pkgname = hocr-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42078ea53e74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
+pkgname='hocr-tools'
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Tools for manipulating and evaluating the hOCR format for representing multi-lingual OCR results by embedding them into HTML.'
+arch=(any)
+url=https://github.com/tmbdev
+license=(Apache)
+depends=(python)
+makedepends=(python-setuptools python-pillow python-lxml python-reportlab)
+
+source=("${url}/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('0d3fb25e48b812afc7293b0e84bda68995ccdec627befe4607be5b79b82f508b')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}