summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 17:47:09 +0200
committerwillemw122015-06-08 17:47:09 +0200
commit69dcc41b1fb5da2205111fc6986e54bf082b9606 (patch)
treec2e6b0ba614bde52e97c756e11265f89533c6b45
downloadaur-69dcc41b1fb5da2205111fc6986e54bf082b9606.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--urssus.install12
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bc0cbf2cb5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = urssus
+ pkgdesc = Multiplatform PyQt-based RSS news aggregator
+ pkgver = 0.2.13
+ pkgrel = 12
+ url = http://urssus.googlecode.com/
+ install = urssus.install
+ arch = any
+ license = GPL2
+ license = LGPL2
+ makedepends = desktop-file-utils
+ makedepends = python2-setuptools
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = python2-sqlalchemy
+ depends = python2-elixir
+ depends = python2-processing
+ depends = python2-pyqt
+ depends = python2-simplejson
+ source = http://pypi.python.org/packages/source/u/uRSSus/uRSSus-0.2.13.tar.gz
+ md5sums = 43c49f800c67d5898cea70dc146ca1f7
+
+pkgname = urssus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09d9c10715cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: willemw <willemw12@gmail.ccom>
+# Contributor: Roberto Alsina <ralsina@kde.org>
+# Contributor: Lex Black <autumn-wind at web dot de>
+
+_pkgname=uRSSus
+pkgname=urssus
+pkgver=0.2.13
+pkgrel=12
+pkgdesc="Multiplatform PyQt-based RSS news aggregator"
+arch=('any')
+url="http://urssus.googlecode.com/"
+license=('GPL2' 'LGPL2')
+depends=('desktop-file-utils' 'gtk-update-icon-cache' 'python2-sqlalchemy'
+ 'python2-elixir' 'python2-processing' 'python2-pyqt' 'python2-simplejson')
+makedepends=('desktop-file-utils' 'python2-setuptools') # 'python2-paver'
+install=$pkgname.install
+source=(http://pypi.python.org/packages/source/u/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('43c49f800c67d5898cea70dc146ca1f7')
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ # Patch
+ sed -i '/pyxml/d' uRSSus.egg-info/requires.txt pavement.py
+}
+
+package() {
+ cd $_pkgname-$pkgver
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 uRSSus.desktop "$pkgdir/usr/share/applications/uRSSus.desktop"
+ install -Dm644 urssus/images/urssus.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/urssus.png"
+
+ # Additional license information
+ install -Dm644 README "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/urssus.install b/urssus.install
new file mode 100644
index 000000000000..b0e216eba064
--- /dev/null
+++ b/urssus.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}