summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-12 18:05:15 +0200
committerGoliathLabs2020-05-12 18:05:15 +0200
commit69e895dbd4958cd70fac6a9cd9789146267f2e93 (patch)
tree1defedd35dbb9b31f1ce1e4e40e1024f60263ebe
parent9d42e5039327ef6471a9b9891cf91bd8421093dd (diff)
downloadaur-69e895dbd4958cd70fac6a9cd9789146267f2e93.tar.gz
Updated: 10.4.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--apache.example.conf1
-rw-r--r--owncloud.hook14
4 files changed, 38 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b49a5d44cb..f2bcb8ebe452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = owncloud
- pkgdesc = A cloud server to store your files centrally on a hardware controlled by you
- pkgver = 10.0.9
+ pkgdesc = Securely access and share data from everywhere and any device
+ pkgver = 10.4.1
pkgrel = 1
url = https://owncloud.org/
arch = any
license = GPL
- depends = php-gd
optdepends = php-apache: to use the Apache web server
optdepends = php-sqlite: to use the SQLite database backend
optdepends = php-pgsql: to use the PostgreSQL database backend
optdepends = php-ldap: LDAP authentication
optdepends = php-intl
optdepends = php-apcu
- optdepends = php-xcache
optdepends = mariadb: to use the MySQL database backend
optdepends = smbclient: to mount SAMBA shares
optdepends = php-mcrypt
@@ -22,13 +20,18 @@ pkgbase = owncloud
replaces = owncloud-app-gallery
options = !strip
backup = etc/webapps/owncloud/apache.example.conf
- source = https://download.owncloud.org/community/owncloud-10.0.9.tar.bz2
- source = https://download.owncloud.org/community/owncloud-10.0.9.tar.bz2.asc
+ source = https://download.owncloud.org/community/owncloud-10.4.1.tar.bz2
+ source = https://download.owncloud.org/community/owncloud-10.4.1.tar.bz2.asc
source = apache.example.conf
+ source = owncloud.hook
validpgpkeys = E3036906AD9F30807351FAC32D5D5E97F6978A26
- sha256sums = 767faedf7b236b469e71ad73a70c6250fc33fd493708d95cf31b0b58b4710973
+ sha256sums = 63f32048225c6bc4534c6757e8beee65fc845a35126899e85d787a3ba4073d48
sha256sums = SKIP
- sha256sums = 4a2ad4b4ecc6ede355bec9a21cbf8c8c4b9144033bdf0ed3366617bcb4df1144
+ sha256sums = e19149bbe2fef90d2d669ca8912104f6cf3c435a6c19610b00c844230190f0fb
+ sha256sums = fae2a021055a7bcf2ceece645e15a921aecefab088583a3f8c4d7d969578a36e
pkgname = owncloud
+ depends = php>=7.4.0
+ depends = php<7.5.0
+ depends = php-gd
diff --git a/PKGBUILD b/PKGBUILD
index 3b583365a32f..89db5565ef3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: Damian Nowak <nowaker@virtkick.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Damian Nowak <nowaker@virtkick.com>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
# Based on owncloud-git PKGBUILD by Alexander Ovsyannikov
pkgname=owncloud
-pkgver=10.0.9
+pkgver=10.4.1
pkgrel=1
-pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
+pkgdesc="Securely access and share data from everywhere and any device"
arch=('any')
url="https://owncloud.org/"
license=('GPL')
-depends=('php-gd')
+depends=()
optdepends=('php-apache: to use the Apache web server'
'php-sqlite: to use the SQLite database backend'
'php-pgsql: to use the PostgreSQL database backend'
'php-ldap: LDAP authentication'
'php-intl'
'php-apcu'
- 'php-xcache'
'mariadb: to use the MySQL database backend'
'smbclient: to mount SAMBA shares'
'php-mcrypt'
@@ -30,13 +30,16 @@ backup=('etc/webapps/owncloud/apache.example.conf')
validpgpkeys=('E3036906AD9F30807351FAC32D5D5E97F6978A26')
source=("https://download.owncloud.org/community/owncloud-${pkgver}.tar.bz2"{,.asc}
'apache.example.conf'
+ 'owncloud.hook'
)
-sha256sums=('767faedf7b236b469e71ad73a70c6250fc33fd493708d95cf31b0b58b4710973'
+sha256sums=('63f32048225c6bc4534c6757e8beee65fc845a35126899e85d787a3ba4073d48'
'SKIP'
- '4a2ad4b4ecc6ede355bec9a21cbf8c8c4b9144033bdf0ed3366617bcb4df1144'
-)
+ 'e19149bbe2fef90d2d669ca8912104f6cf3c435a6c19610b00c844230190f0fb'
+ 'fae2a021055a7bcf2ceece645e15a921aecefab088583a3f8c4d7d969578a36e')
package() {
+ depends=('php>=7.4.0' 'php<7.5.0' 'php-gd')
+
# install license
install -d "$pkgdir"/usr/share/licenses/${pkgname}
cp "$srcdir"/${pkgname}/COPYING "$pkgdir"/usr/share/licenses/${pkgname}
@@ -60,4 +63,6 @@ package() {
find "$pkgdir"/usr/share/webapps/${pkgname} -type d -exec chmod 0755 {} \;
chmod a+x "$pkgdir"/usr/share/webapps/${pkgname}/occ
+
+# install -Dm0644 "$srcdir"/owncloud.hook "$pkgdir"/usr/share/libalpm/hooks/owncloud.hook
}
diff --git a/apache.example.conf b/apache.example.conf
index 6c6ab87d0d26..988e20017eb2 100644
--- a/apache.example.conf
+++ b/apache.example.conf
@@ -6,7 +6,6 @@
Options FollowSymlinks
AllowOverride all
Require all granted
- php_admin_value open_basedir "/srv/http/:/dev/urandom:/tmp/:/usr/share/pear/:/usr/share/webapps/owncloud/:/etc/webapps/owncloud"
</Directory>
<VirtualHost *:80>
diff --git a/owncloud.hook b/owncloud.hook
new file mode 100644
index 000000000000..e7efc8d4b9d4
--- /dev/null
+++ b/owncloud.hook
@@ -0,0 +1,14 @@
+# Update ownCloud when core or -apps are touched
+
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Type = Package
+Target = owncloud
+Target = owncloud-app-*
+
+[Action]
+Description = Updating ownCloud installation
+When = PostTransaction
+Exec = /usr/bin/runuser -u http -- /usr/bin/php /usr/share/webapps/owncloud/occ upgrade
+