summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-04-04 20:27:01 +0200
committerJosip Ponjavic2018-04-04 20:27:01 +0200
commit69ec2e6f7faed16f159a29ce8181be18457861b5 (patch)
tree0cb0a1efd03069e705129b110e37833a70d773a4
parentf505ae37d62d30cf055a0bba592ed14646f593e5 (diff)
downloadaur-69ec2e6f7faed16f159a29ce8181be18457861b5.tar.gz
upgpkg: 0.7-3 fix build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--imagewriter.patch39
3 files changed, 58 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9327f8ae7ad..fe35731bc5af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = ffmpegthumbs-mattepaint
pkgdesc = An alternative version of the standard KDE ffmpegthumbs.
pkgver = 0.7
- pkgrel = 2
+ pkgrel = 3
url = http://kde-look.org/content/show.php/FFMpegThumbs-MattePaint?content=153902
- arch = i686
arch = x86_64
license = GPL
makedepends = extra-cmake-modules
- depends = ffmpeg
depends = kio
- source = ffmpegthumbs-mattepaint-0.7.tar.gz::https://dl.opendesktop.org/api/files/download/id/1467623621/153902-Upload2016060900.tar.gz
+ depends = libavcodec.so
+ depends = libavfilter.so
+ depends = libavformat.so
+ depends = libavutil.so
+ depends = libswscale.so
+ source = ffmpegthumbs-mattepaint-0.7.tar.gz::https://dl.opendesktop.org/api/files/downloadfile/id/1467623621/s/b05dc6ee78a6106471cd994e86695c6f/t/1522867138/u/40596/153902-Upload2016060900.tar.gz
+ source = imagewriter.patch
sha256sums = 2e4c9fe5e85d9c14b1c468e0dcaecfd71b378ca38f051c0beea6a5f04b5c6cd4
+ sha256sums = fe67a5f0599bfd53dfe8629d09e7ee39bd41e3877cfb2b0bb77a4c9467cc42b1
pkgname = ffmpegthumbs-mattepaint
diff --git a/PKGBUILD b/PKGBUILD
index 705e454b684f..b57b30e01c6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
pkgname=ffmpegthumbs-mattepaint
pkgver=0.7
-pkgrel=2
+pkgrel=3
pkgdesc="An alternative version of the standard KDE ffmpegthumbs."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://kde-look.org/content/show.php/FFMpegThumbs-MattePaint?content=153902"
license=('GPL')
-depends=('ffmpeg' 'kio')
+depends=('kio' 'libavcodec.so' 'libavfilter.so' 'libavformat.so' 'libavutil.so' 'libswscale.so')
makedepends=('extra-cmake-modules')
-source=("${pkgname}-${pkgver}.tar.gz::https://dl.opendesktop.org/api/files/download/id/1467623621/153902-Upload2016060900.tar.gz")
-sha256sums=('2e4c9fe5e85d9c14b1c468e0dcaecfd71b378ca38f051c0beea6a5f04b5c6cd4')
+source=("${pkgname}-${pkgver}.tar.gz::https://dl.opendesktop.org/api/files/downloadfile/id/1467623621/s/b05dc6ee78a6106471cd994e86695c6f/t/1522867138/u/40596/153902-Upload2016060900.tar.gz"
+ 'imagewriter.patch')
+sha256sums=('2e4c9fe5e85d9c14b1c468e0dcaecfd71b378ca38f051c0beea6a5f04b5c6cd4'
+ 'fe67a5f0599bfd53dfe8629d09e7ee39bd41e3877cfb2b0bb77a4c9467cc42b1')
prepare() {
mkdir -p build
+ cd 'Upload2016060900'
+ patch -p1 -i ../imagewriter.patch
}
build() {
@@ -27,6 +31,5 @@ build() {
}
package() {
- cd build
- make DESTDIR=$pkgdir install
+ make -C build DESTDIR=$pkgdir install
}
diff --git a/imagewriter.patch b/imagewriter.patch
new file mode 100644
index 000000000000..5d249293cba1
--- /dev/null
+++ b/imagewriter.patch
@@ -0,0 +1,39 @@
+diff -ruN "a/KF5/0.7 using ffmpeg-3.0/ffmpegthumbs-mattepaint/ffmpegthumbnailer/imagewriter.cpp" "b/KF5/0.7 using ffmpeg-3.0/ffmpegthumbs-mattepaint/ffmpegthumbnailer/imagewriter.cpp"
+--- "a/KF5/0.7 using ffmpeg-3.0/ffmpegthumbs-mattepaint/ffmpegthumbnailer/imagewriter.cpp" 2016-05-29 20:37:24.000000000 +0200
++++ "b/KF5/0.7 using ffmpeg-3.0/ffmpegthumbs-mattepaint/ffmpegthumbnailer/imagewriter.cpp" 2018-04-04 20:10:22.937314418 +0200
+@@ -62,7 +62,7 @@
+ if (q1.exists()){
+ QImage matteImage(QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/ffmpegthumbs-mattepaint/quadrant1");
+ QPainter painter(&image);
+- if ((image.height() <= 128) and (image.width() <= 128)) {
++ if ((image.height() <= 128) && (image.width() <= 128)) {
+ painter.drawImage( 0, 0, matteImage.scaled(128, 128, Qt::KeepAspectRatio, Qt::FastTransformation));
+ } else {
+ painter.drawImage( 0, 0, matteImage);
+@@ -73,7 +73,7 @@
+ QImage matteImage(QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/ffmpegthumbs-mattepaint/quadrant2");
+ mirror = image.mirrored(true, false);
+ QPainter painter(&mirror);
+- if ((image.height() <= 128) and (image.width() <= 128)) {
++ if ((image.height() <= 128) && (image.width() <= 128)) {
+ painter.drawImage( 0, 0, matteImage.scaled(128, 128, Qt::KeepAspectRatio, Qt::FastTransformation));
+ } else {
+ painter.drawImage( 0, 0, matteImage);
+@@ -85,7 +85,7 @@
+ QImage matteImage(QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/ffmpegthumbs-mattepaint/quadrant3");
+ mirror = image.mirrored(false, true);
+ QPainter painter(&mirror);
+- if ((image.height() <= 128) and (image.width() <= 128)) {
++ if ((image.height() <= 128) && (image.width() <= 128)) {
+ painter.drawImage( 0, 0, matteImage.scaled(128, 128, Qt::KeepAspectRatio, Qt::FastTransformation));
+ } else {
+ painter.drawImage( 0, 0, matteImage);
+@@ -97,7 +97,7 @@
+ QImage matteImage(QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/ffmpegthumbs-mattepaint/quadrant4");
+ mirror = image.mirrored(true, true);
+ QPainter painter(&mirror);
+- if ((image.height() <= 128) and (image.width() <= 128)) {
++ if ((image.height() <= 128) && (image.width() <= 128)) {
+ painter.drawImage( 0, 0, matteImage.scaled(128, 128, Qt::KeepAspectRatio, Qt::FastTransformation));
+ } else {
+ painter.drawImage( 0, 0, matteImage);