summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author2xsaiko2020-05-04 16:29:43 +0200
committer2xsaiko2020-05-04 16:29:43 +0200
commit6a05c755e9503c3904032fab9c7cc11e19907d39 (patch)
tree97eb6840d05cac30ec2829f378c8843ab673a740
downloadaur-6a05c755e9503c3904032fab9c7cc11e19907d39.tar.gz
Initial upload: flora-git r10.63aa99e-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..563891dbf078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = flora-git
+ pkgdesc = Fabric Lightweight Obfuscation Remapping Assistant
+ pkgver = r10.63aa99e
+ pkgrel = 1
+ url = https://github.com/Parzivail-Modding-Team/FLORA
+ arch = any
+ license = MIT
+ makedepends = dotnet-sdk
+ depends = dotnet-runtime
+ provides = flora
+ conflicts = flora
+ source = flora::git+https://github.com/Parzivail-Modding-Team/FLORA.git
+ sha512sums = SKIP
+
+pkgname = flora-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e31a1884b62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=flora-git
+_pkgname=${pkgname%-git}
+pkgver=r10.63aa99e
+pkgrel=1
+pkgdesc="Fabric Lightweight Obfuscation Remapping Assistant"
+arch=("any")
+url="https://github.com/Parzivail-Modding-Team/FLORA"
+license=("MIT")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=("dotnet-runtime")
+makedepends=("dotnet-sdk")
+source=("${_pkgname}::git+https://github.com/Parzivail-Modding-Team/FLORA.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ dotnet publish -c Release --no-self-contained -o "build/" FLORA.sln
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -dm755 "${pkgdir}/usr/bin/"
+ install -dm755 "${pkgdir}/usr/lib/flora/"
+
+ cp -r build/* "${pkgdir}/usr/lib/flora/"
+ ln -s "/usr/lib/flora/FLORA" "${pkgdir}/usr/bin/FLORA"
+
+ install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
+}