summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit6a540240ad479521d79db4dbdce1b3ec2cd36300 (patch)
tree26dac85386bacc6f0491491759bf13acec491652
downloadaur-6a540240ad479521d79db4dbdce1b3ec2cd36300.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d152b4aa5fff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wbxml2
+ pkgdesc = Library and Tools to parse, encode and handle WBXML documents
+ pkgver = 0.9.2
+ pkgrel = 5
+ url = http://libwbxml.aymerick.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = m4
+ makedepends = automake
+ depends = zlib
+ depends = expat
+ depends = popt
+ depends = libxml2
+ source = http://downloads.sourceforge.net/sourceforge/wbxmllib/wbxml2-0.9.2.tar.gz
+ md5sums = 67a48fd9b69db8818a4dca5375c7993a
+
+pkgname = wbxml2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a78ce5bddd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Giorgio Lando <patroclo7@gmail.com>
+# Contributor: Hauke Wesselmann <hauke@h-dawg.de>
+pkgname=wbxml2
+pkgver=0.9.2
+pkgrel=5
+pkgdesc="Library and Tools to parse, encode and handle WBXML documents"
+arch=('i686' 'x86_64')
+url="http://libwbxml.aymerick.com"
+license=(GPL)
+depends=('zlib' 'expat' 'popt' 'libxml2')
+makedepends=('libtool' 'autoconf' 'm4' 'automake')
+source=(http://downloads.sourceforge.net/sourceforge/wbxmllib/${pkgname}-${pkgver}.tar.gz)
+md5sums=('67a48fd9b69db8818a4dca5375c7993a')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ chmod +x bootstrap
+ ./bootstrap
+ mkdir doc
+ touch doc/empty
+ ./configure --prefix=/usr
+ make all || return 1
+ make DESTDIR=${startdir}/pkg install
+}
+