summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-06-30 12:39:30 +0200
committerAleksandar Trifunovic2018-06-30 12:39:30 +0200
commit6a9a1c70d8f49e4e506c89eff4d6c2c8e06fff9d (patch)
treea46c68f18c50ecafe945e742466f89df0824694e
parent764390a8c00e3dbba95685679d983ae757207282 (diff)
downloadaur-6a9a1c70d8f49e4e506c89eff4d6c2c8e06fff9d.tar.gz
v2.6.2; fix boost dependencies; minor cleanups
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65b2a9995663..393c3cc09b89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = valhalla
pkgdesc = Routing engine for OpenStreetMap.
- pkgver = 2.6.1
+ pkgver = 2.6.2
pkgrel = 1
url = https://github.com/valhalla/valhalla
arch = x86_64
@@ -9,15 +9,16 @@ pkgbase = valhalla
makedepends = git
makedepends = vim
makedepends = jq
+ makedepends = boost
+ makedepends = rapidjson
depends = prime_server
- depends = boost
+ depends = boost-libs
depends = protobuf
depends = python
depends = lua
depends = libspatialite
- depends = rapidjson
- source = https://github.com/valhalla/valhalla/archive/2.6.1.tar.gz
- sha256sums = 30321f370e825be94ba49e21fef6d49bbe2267d16d9c78b228d263aa0d830d1c
+ source = https://github.com/valhalla/valhalla/archive/2.6.2.tar.gz
+ sha256sums = d6efbda5d66ea20dddf070dc70e9b4891270df2d3fa06d801f0f800aab011126
pkgname = valhalla
diff --git a/PKGBUILD b/PKGBUILD
index c510987bf0f0..8767fb89c272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
# Maintainer: Aleksandar Trifunović <akstrfn@gmail.com>
pkgname=valhalla
-pkgver=2.6.1
+pkgver=2.6.2
pkgrel=1
pkgdesc="Routing engine for OpenStreetMap."
arch=('x86_64')
url="https://github.com/valhalla/valhalla"
license=('custom:MIT')
-depends=('prime_server' 'boost' 'protobuf' 'python' 'lua' 'libspatialite' 'rapidjson')
-makedepends=('cmake' 'git' 'vim' 'jq')
-source=("https://github.com/valhalla/valhalla/archive/$pkgver.tar.gz")
-sha256sums=('30321f370e825be94ba49e21fef6d49bbe2267d16d9c78b228d263aa0d830d1c')
+depends=('prime_server' 'boost-libs' 'protobuf' 'python' 'lua' 'libspatialite')
+makedepends=('cmake' 'git' 'vim' 'jq' 'boost' 'rapidjson')
+source=("${url}/archive/$pkgver.tar.gz")
+sha256sums=('d6efbda5d66ea20dddf070dc70e9b4891270df2d3fa06d801f0f800aab011126')
prepare() {
cd "$pkgname-$pkgver"
git clone --depth=1 https://github.com/scrosby/OSM-binary third_party/OSM-binary
git clone --depth=1 https://github.com/valhalla/osmlr-tile-spec third_party/OSMLR
+
+ # TODO this seems fixed but tests are failing upstream anyway
# There is probably a better way to solve this. Sources:
# https://groups.google.com/forum/#!topic/spatialite-users/YXnofHixXsM
# https://github.com/valhalla/valhalla/issues/354
sed -i 's/mod_spatialite/\/usr\/lib\/mod_spatialite/' src/mjolnir/admin.cc
-
- # Make locales necessary for testing
- cd locales
- ./make_locales.sh
}
build() {
@@ -52,11 +50,9 @@ package() {
cd "$pkgname-$pkgver"
cmake --build build -- DESTDIR="$pkgdir/" install
rm -rf "$pkgdir/usr/share/doc/"{libvalhalla-dev,libvalhalla0,python-valhalla}
- rm -rf "$pkgdir/usr/share/doc/$pkgname/ChangeLog"
+ rm "$pkgdir/usr/share/doc/$pkgname/ChangeLog"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/$pkgname/CHANGELOG"
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 COPYING README.md CHANGELOG.md -t "$pkgdir/usr/share/licenses/$pkgname"
cp -a docs/* "$pkgdir/usr/share/doc/$pkgname/"
}