summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2023-06-09 22:14:34 +1000
committerVictor Tran2023-06-09 22:14:34 +1000
commit6a9f8928cdbb2aefb66c9ec0b515ce8e424a8c8f (patch)
treeb31223f7dcb6fa365f90c54a5d7a36660c47eefb
parente4b6547049c25d56efd95ef4347a33b63babee21 (diff)
downloadaur-6a9f8928cdbb2aefb66c9ec0b515ce8e424a8c8f.tar.gz
Update to 5.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD41
2 files changed, 42 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf25c54fc535..73479c8567ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = thefile
pkgdesc = File Manager
- pkgver = 4.0.2
+ pkgver = 5.0
pkgrel = 0
- url = https://github.com/vicr123/thefile
+ url = https://github.com/theCheeseboard/thefile
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = git
- makedepends = qt5-tools
- depends = xdg-utils
- depends = qt5-base
- depends = the-libs
- depends = libtdesktopenvironment
- depends = libthefrisbee
- depends = qt5-svg
- source = git+https://github.com/vicr123/thefile#tag=v4.0.2
- sha256sums = SKIP
+ makedepends = qt6-tools
+ makedepends = cmake
+ makedepends = clang
+ makedepends = quazip-qt6
+ makedepends = libimobiledevice
+ source = thefile-5.0::https://github.com/theCheeseboard/thefile/archive/refs/tags/v5.0.tar.gz
+ sha256sums = 0a84231b8d85ee22f0bd2989ee290917bd3003b50d70558249e1838ce4cfd4a0
pkgname = thefile
+ depends = libimobiledevice
+ depends = quazip-qt6
+ depends = libthefile
+
+pkgname = libthefile
+ depends = libtdesktopenvironment
+ depends = libthefrisbee
diff --git a/PKGBUILD b/PKGBUILD
index b226463c2012..47c5390a4590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,34 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
-pkgname=thefile
-pkgver=4.0.2
+pkgname=('thefile' 'libthefile')
+pkgver=5.0
pkgrel=0
pkgdesc="File Manager"
-arch=("x86_64")
-url="https://github.com/vicr123/thefile"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/thefile"
license=('GPL3')
-depends=('xdg-utils' 'qt5-base' 'the-libs' 'libtdesktopenvironment' 'libthefrisbee' 'qt5-svg')
-makedepends=('git' 'qt5-tools')
-source=("git+https://github.com/vicr123/thefile#tag=v$pkgver")
-sha256sums=('SKIP')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang' 'quazip-qt6' 'libimobiledevice')
+source=("thefile-$pkgver"::"https://github.com/theCheeseboard/thefile/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('0a84231b8d85ee22f0bd2989ee290917bd3003b50d70558249e1838ce4cfd4a0')
+
+doInstallModule() {
+ DESTDIR="$pkgdir" cmake --install "build/$1"
+}
build() {
- cd thefile
- mkdir -p build
- cd build
- qmake ../theFile.pro
- make
+ cmake -B build -S "thefile-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package_thefile() {
+ depends=('libimobiledevice' 'quazip-qt6' 'libthefile')
+
+ doInstallModule 'application'
+ doInstallModule 'plugins'
}
-package() {
- cd thefile/build
- make install INSTALL_ROOT=$pkgdir
+package_libthefile() {
+ depends=('libtdesktopenvironment' 'libthefrisbee')
+
+ doInstallModule 'libthefile'
}