summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-29 14:54:43 -0600
committerMark Wagie2021-10-29 14:54:43 -0600
commit6aa9f0d2ab33de8a4d1b1a1c28fdcf68b2fe8d3b (patch)
treeaedbb9df17ce5d52df30f7568b3be0846933bf0f
parent3418d7d805b0d9808fe49d7c1dea08cb31b8acd9 (diff)
downloadaur-6aa9f0d2ab33de8a4d1b1a1c28fdcf68b2fe8d3b.tar.gz
update patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa5152f64714..1aa3e14f6f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-multi-monitors-add-on-git
pkgdesc = Adds panels and thumbnails for additional monitors.
pkgver = 23.r0.g0cec99d
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/spin83/multi-monitors-add-on
arch = any
license = GPL2
@@ -12,6 +12,6 @@ pkgbase = gnome-shell-extension-multi-monitors-add-on-git
source = git+https://github.com/spin83/multi-monitors-add-on.git
source = https://github.com/spin83/multi-monitors-add-on/pull/159.patch
sha256sums = SKIP
- sha256sums = e9f7f7c71c52fa88b7a231804e2bc877bff6799c65b339d7f818c921d1b3a354
+ sha256sums = 13019cce907dd59f531ab56d4425139f41752590e2e9fd79b571a75ec3c1657e
pkgname = gnome-shell-extension-multi-monitors-add-on-git
diff --git a/PKGBUILD b/PKGBUILD
index 72c364ec506d..9c14bb860002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gnome-shell-extension-multi-monitors-add-on-git
_pkgname=multi-monitors-add-on
pkgver=23.r0.g0cec99d
-pkgrel=2
+pkgrel=3
pkgdesc="Adds panels and thumbnails for additional monitors."
arch=('any')
url="https://github.com/spin83/multi-monitors-add-on"
@@ -13,10 +13,10 @@ depends=('gnome-shell')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/spin83/multi-monitors-add-on.git'\
+source=('git+https://github.com/spin83/multi-monitors-add-on.git'
'https://github.com/spin83/multi-monitors-add-on/pull/159.patch')
sha256sums=('SKIP'
- 'e9f7f7c71c52fa88b7a231804e2bc877bff6799c65b339d7f818c921d1b3a354')
+ '13019cce907dd59f531ab56d4425139f41752590e2e9fd79b571a75ec3c1657e')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -31,22 +31,18 @@ prepare() {
}
package() {
- _uuid="$_pkgname@spin83"
-
cd "$srcdir/$_pkgname"
- for locale in "$_uuid"/locale/*/; do
- install -Dm644 -t "$pkgdir/usr/share/${locale}/LC_MESSAGES" \
- "${locale}/LC_MESSAGES"/*.mo
- done
+ _uuid="$_pkgname@spin83"
+ _schema="org.gnome.shell.extensions.$_pkgname.gschema.xml"
+
+ rm "$_uuid/$_pkgname.pot"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- cp -a "$_uuid" "$pkgdir/usr/share/gnome-shell/extensions"
- rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/locale"
- rm "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/$_pkgname.pot"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -a "$_uuid/" "$pkgdir/usr/share/gnome-shell/extensions/"
- install -d "$pkgdir/usr/share/glib-2.0/schemas"
- ln -s "/usr/share/gnome-shell/extensions/$_uuid/schemas/org.gnome.shell.extensions.$_pkgname.gschema.xml" \
- "$pkgdir/usr/share/glib-2.0/schemas"
+ install -d "$pkgdir/usr/share/glib-2.0/schemas/"
+ ln -s "/usr/share/gnome-shell/extensions/$_uuid/schemas/$_schema" \
+ "$pkgdir/usr/share/glib-2.0/schemas/"
}