summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-11-05 22:24:44 +0100
committerCarsten Teibes2014-11-05 22:24:44 +0100
commit6ac60440d1af02ad92977ed81a722b17674df59a (patch)
tree66b9e997847f308f8926d44d5152749e817ae332
downloadaur-6ac60440d1af02ad92977ed81a722b17674df59a.tar.gz
[add] httpry 0.1.8
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40cf1198be4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = httpry
+ pkgdesc = A specialized packet sniffer designed for displaying and logging HTTP traffic.
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = http://dumpsterventures.com/jason/httpry/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libpcap
+ optdepends = perl: if you want to use the scripts/plugins
+ source = http://dumpsterventures.com/jason/httpry/httpry-0.1.8.tar.gz
+ sha256sums = ef53454f895f68005f7b9ab634d1b433c4df839eacea9109e4ee48d4296fb613
+
+pkgname = httpry
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cc2b474a3c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Wolfen <rostov344-arch at yahoo dot fr>
+
+pkgname=httpry
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="A specialized packet sniffer designed for displaying and logging HTTP traffic."
+arch=('i686' 'x86_64')
+url="http://dumpsterventures.com/jason/httpry/"
+license=('GPL2')
+depends=("libpcap")
+optdepends=('perl: if you want to use the scripts/plugins')
+source=("http://dumpsterventures.com/jason/httpry/httpry-$pkgver.tar.gz")
+sha256sums=('ef53454f895f68005f7b9ab634d1b433c4df839eacea9109e4ee48d4296fb613')
+
+build() {
+ make -C $pkgname-$pkgver
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ # bin + man
+ install -Dm755 httpry "$pkgdir"/usr/bin/httpry
+ install -Dm644 httpry.1 "$pkgdir"/usr/share/man/man1/httpry.1
+
+ # scripts
+ install -Dm644 scripts/parse_log.pl "$pkgdir"/usr/lib/httpry/scripts/parse_log.pl
+ cp -rup scripts/plugins "$pkgdir"/usr/lib/httpry/scripts/
+ ln -s /usr/share/doc/httpry/perl-tools "$pkgdir"/usr/lib/httpry/scripts/perl-tools
+
+ # docs
+ install -d "$pkgdir"/usr/share/doc/httpry
+ install -m644 doc/* "$pkgdir"/usr/share/doc/httpry
+}