summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohngowers2020-04-26 11:11:34 +0100
committerjohngowers2020-04-26 11:40:36 +0100
commit6ad0a38d0aed54b430c3f17a3a2a1cc17520da89 (patch)
tree03a870a8ca4f4427dd54f9b0598f9c8826c99f4a
parent7e5f1d73e0f1d155253ff4f10be880eec129ae86 (diff)
downloadaur-6ad0a38d0aed54b430c3f17a3a2a1cc17520da89.tar.gz
Added missing dependencies and modified PKGBUILD to build after upstream commit 5dd03673969.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 872f805559d1..180fbce0542b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = agda-git
pkgdesc = A dependently typed functional programming language and proof assistant: development version
- pkgver = 2.6.0.r0.g16eb89fb0
+ pkgver = 2.5.1.r8151.g4108da695
pkgrel = 1
url = http://wiki.portal.chalmers.se/agda/
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = agda-git
makedepends = ghc
depends = ghc-libs
depends = haskell-async
+ depends = haskell-bifunctors
depends = haskell-blaze-html
depends = haskell-boxes
depends = haskell-cpphs
@@ -19,11 +20,14 @@ pkgbase = agda-git
depends = haskell-edisoncore
depends = haskell-edit-distance
depends = haskell-equivalence
+ depends = haskell-filemanip
+ depends = haskell-aeson
depends = haskell-geniplate-mirror
depends = haskell-gitrev
depends = haskell-hashable
depends = haskell-hashtables
depends = haskell-ieee754
+ depends = haskell-monad-control
depends = haskell-murmur-hash
depends = haskell-regex-tdfa
depends = haskell-strict
diff --git a/PKGBUILD b/PKGBUILD
index a1f591a0ac7d..173b0ced9e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Patch to v2.6.0 supplied by Sean Anderson <seanga2 AT gmail DOT com>
# See also the 'agda' package in the 'community' repository.
pkgname=agda-git
-pkgver=2.6.0.r0.g16eb89fb0
+pkgver=2.5.1.r8151.g4108da695
pkgrel=1
pkgdesc="A dependently typed functional programming language and proof assistant: development version"
arch=('x86_64')
url="http://wiki.portal.chalmers.se/agda/"
license=('custom')
groups=()
-depends=('ghc-libs' 'haskell-async' 'haskell-blaze-html' 'haskell-boxes'
+depends=('ghc-libs' 'haskell-async' 'haskell-bifunctors' 'haskell-blaze-html' 'haskell-boxes'
'haskell-cpphs' 'haskell-data-hash' 'haskell-edisonapi' 'haskell-edisoncore'
'haskell-edit-distance' 'haskell-equivalence' 'haskell-filemanip' 'haskell-aeson'
'haskell-geniplate-mirror' 'haskell-gitrev' 'haskell-hashable' 'haskell-hashtables'
- 'haskell-ieee754' 'haskell-murmur-hash' 'haskell-regex-tdfa' 'haskell-strict'
+ 'haskell-ieee754' 'haskell-monad-control' 'haskell-murmur-hash' 'haskell-regex-tdfa' 'haskell-strict'
'haskell-unordered-containers' 'haskell-uri-encode' 'haskell-zlib')
makedepends=('git' 'alex' 'happy' 'ghc')
optdepends=('agda-stdlib: for standard library')
@@ -33,7 +33,7 @@ pkgver() {
}
prepare() {
- sed -e "s|(\"Agda_datadir\", agda_datadir) : e|[(\"Agda_datadir\",agda_datadir), (\"LD_LIBRARY_PATH\", \"$PWD/${pkgname%-git}/dist/build\")] ++ e|" \
+ sed -e "s|(\"Agda_datadir\", agda_datadir) : e|[(\"Agda_datadir\",agda_datadir), (\"LD_LIBRARY_PATH\", \"$pkgdir/usr/lib\")] ++ e|" \
-i "${pkgname%-git}/Setup.hs"
sed -i 's/== 0.5/>= 0.5/' "${pkgname%-git}/Agda.cabal"