summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-02-18 15:00:57 +0100
committerPhilipp A2018-02-18 15:00:57 +0100
commit6b0392b1f223c051f56df316b06cfdd046d52fd1 (patch)
tree162e686cbdc027869d46fa4c3219c2c8806d2a4d
parentee2b73c23e5a9de63b3ba85e1c0721658172d41a (diff)
downloadaur-6b0392b1f223c051f56df316b06cfdd046d52fd1.tar.gz
Use wheel
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e19502eaa7f..a7e0e1939f94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-schema
pkgdesc = Python module to validate and convert data structures.
pkgver = 0.6.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/keleshev/schema
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-pytest
- makedepends = python2-setuptools
- makedepends = python2-pytest
- source = schema-0.6.7.tar.gz::https://github.com/keleshev/schema/archive/v0.6.7.tar.gz
- sha1sums = 02674b4ae3fe44957379da5f70bf03c3b12b2647
+ makedepends = python-pip
+ makedepends = python2-pip
+ noextract = schema-0.6.7-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/s/schema/schema-0.6.7-py2.py3-none-any.whl
+ sha256sums = a058daf5d926e4ece9f13c4c2366a836143ca7913ef053c5023c569e00175b2a
pkgname = python2-schema
diff --git a/.gitignore b/.gitignore
index 24f2ec57e666..ff79a45d3892 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/pkg/
/src/
/*.pkg.tar.xz
-/*.tar.gz
+/*.whl
+
diff --git a/PKGBUILD b/PKGBUILD
index cab6dbcaddfd..6c7affa690d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
# Contributor: Vladimir Keleshev <vladimir [at] keleshev [dot] com>
-# Maintainer: ???
_name=schema
pkgbase="python-$_name"
pkgname=("python2-$_name" "python-$_name")
pkgver=0.6.7
-pkgrel=1
+pkgrel=2
pkgdesc='Python module to validate and convert data structures.'
-arch=('any')
+arch=(any)
url="https://github.com/keleshev/$_name"
-license=('MIT')
-makedepends=('python-setuptools' 'python-pytest'
- 'python2-setuptools' 'python2-pytest')
-source=("$_name-$pkgver.tar.gz::https://github.com/keleshev/$_name/archive/v$pkgver.tar.gz")
-sha1sums=('02674b4ae3fe44957379da5f70bf03c3b12b2647')
-
-check() {
- cd "$_name-$pkgver"
- python2 setup.py test
- python setup.py test
-}
+license=(MIT)
+makedepends=(python-pip python2-pip)
+_wheel="$_name-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+sha256sums=('a058daf5d926e4ece9f13c4c2366a836143ca7913ef053c5023c569e00175b2a')
+noextract=("$_wheel")
do_package() {
- depends=("$1")
- cd "$srcdir/$_name-$pkgver"
- "$1" setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+ depends=($1)
+ $2 install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
}
package_python2-schema() {
- do_package python2
+ do_package python2 pip2
}
package_python-schema() {
- do_package python
+ do_package python pip
}