summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2022-05-08 15:42:01 +0100
committerMatrix2022-05-08 15:42:01 +0100
commit6b0ebbe6a8c799331359b0734006cfd6d4e8132d (patch)
tree672055d36e57d10b9ccd24d3cbc5c9f58bd0e789
parentfaf0b11bd6d64e8368f54c74b040229365e2e096 (diff)
downloadaur-6b0ebbe6a8c799331359b0734006cfd6d4e8132d.tar.gz
made package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
-rw-r--r--gnome-shell-extension.install8
3 files changed, 21 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184b0e62d6e7..4edf05b32f23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Fri May 18 04:08:44 UTC 2018
pkgbase = gnome-shell-extension-datetime-format-git
pkgdesc = Gnome extension which allows users to customise the datetime format on the status bar and date menu.
pkgver = r5.f660b1e
@@ -11,12 +9,9 @@ pkgbase = gnome-shell-extension-datetime-format-git
makedepends = git
makedepends = nodejs
depends = gnome-shell>=3.20
- provides = gnome-shell-extension-datetime-format
- conflicts = gnome-shell-extension-datetime-format
- source = gnome-shell-extension-datetime-format::git+https://github.com/Daniel-Khodabakhsh/datetime-format.git
+ source = git+https://github.com/Daniel-Khodabakhsh/datetime-format.git
source = build.patch
sha256sums = SKIP
sha256sums = ca11b183e163eb143ea3a7ae937df07bd9759ff141764ac09117364cff8fc10d
pkgname = gnome-shell-extension-datetime-format-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2be92d1848cf..5d8cba7c3fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,35 @@
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-
+# Maintainer: <thysupremematrix@tuta.io>
pkgname=gnome-shell-extension-datetime-format-git
pkgver=r5.f660b1e
pkgrel=1
pkgdesc="Gnome extension which allows users to customise the datetime format on the status bar and date menu."
arch=(any)
url="https://github.com/Daniel-Khodabakhsh/datetime-format"
-license=(GPL3)
+license=("GPL3")
depends=('gnome-shell>=3.20')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
makedepends=('git' 'nodejs')
-install='gnome-shell-extension.install'
-source=("${pkgname%-git}"::"git+https://github.com/Daniel-Khodabakhsh/datetime-format.git"
- "build.patch")
+source=("git+https://github.com/Daniel-Khodabakhsh/datetime-format.git" "build.patch")
+install="gnome-shell-extension.install"
sha256sums=('SKIP'
'ca11b183e163eb143ea3a7ae937df07bd9759ff141764ac09117364cff8fc10d')
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+_gitname="datetime-format"
+
+prepare(){
+ cd $srcdir/${_gitname}
+ patch -p1 -i "${srcdir}/build.patch"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "${srcdir}/build.patch"
+pkgver() {
+ cd $srcdir/${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- node build.js system
+ cd "$srcdir/${_gitname}"
+ node build.js system
}
package() {
- cd "$srcdir/${pkgname%-git}"
- cp -a pkg/* $pkgdir/
+ cp -R $srcdir/${_gitname}/pkg/* $pkgdir
}
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
index 484bc1b03f77..3488506f6ca0 100644
--- a/gnome-shell-extension.install
+++ b/gnome-shell-extension.install
@@ -1,7 +1,9 @@
post_install() {
- echo "==> ****************************************************"
- echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
- echo "==> ****************************************************"
+ echo " ______________________________________________________ "
+ echo "==> / \"
+ echo "==> | Don't forget to Restart GNOME Shell |"
+ echo "==> | (Alt+F2, type r) |"
+ echo " \______________________________________________________/"
}
post_upgrade() {