summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-08-22 14:49:51 +0000
committerDaniel Bermond2020-08-22 14:49:51 +0000
commit6b15776aa366baa54e60e0a7a721f28239f29be8 (patch)
tree3c28268ecc1fe812257d4d2e369274225a12366c
parentb91bcc82ae1e9b53ed68db121e41ab4e53e8bd64 (diff)
downloadaur-6b15776aa366baa54e60e0a7a721f28239f29be8.tar.gz
General update with various changes
- change source and url (bitbucket no longer supports mercurial) - change assembler to nasm to enable assembly optimizations (upstream does not support yasm anymore) - drop i686 support - update description - remove unneeded patches - cosmetic changes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD120
-rw-r--r--libx265_main10-soname.patch11
-rw-r--r--libx265_main12-soname.patch11
4 files changed, 50 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a596c8d1f9e..82ce269040b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri Aug 25 15:17:15 UTC 2017
pkgbase = x265-hg
- pkgdesc = Open Source H265/HEVC video encoder
- pkgver = 2.5.r12.fcd9154fa4e2
+ pkgdesc = Open source H.265/HEVC video encoder (hg version)
+ pkgver = 3.4.r11.244186fe0ab6
pkgrel = 1
- url = https://bitbucket.org/multicoreware/x265
- arch = i686
+ url = https://www.videolan.org/developers/x265.html
arch = x86_64
license = GPL
- makedepends = cmake
makedepends = mercurial
- makedepends = yasm
- depends = gcc-libs
+ makedepends = cmake
+ makedepends = nasm
provides = x265
provides = libx265.so
conflicts = x265
- source = hg+https://bitbucket.org/multicoreware/x265
+ source = hg+http://hg.videolan.org/x265
sha256sums = SKIP
pkgname = x265-hg
diff --git a/PKGBUILD b/PKGBUILD
index 58c593f24ee4..9b160dd1ea10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,93 +1,61 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: kfgz <kfgz@interia.pl>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=x265-hg
-pkgver=2.5.r12.fcd9154fa4e2
+pkgver=3.4.r11.244186fe0ab6
pkgrel=1
-pkgdesc='Open Source H265/HEVC video encoder'
-arch=('i686' 'x86_64')
-url='https://bitbucket.org/multicoreware/x265'
+pkgdesc='Open source H.265/HEVC video encoder (hg version)'
+arch=('x86_64')
+url='https://www.videolan.org/developers/x265.html'
license=('GPL')
-depends=('gcc-libs')
-makedepends=('cmake' 'mercurial' 'yasm')
-provides=('x265'
- 'libx265.so')
+makedepends=('mercurial' 'cmake' 'nasm')
+provides=('x265' 'libx265.so')
conflicts=('x265')
-source=('hg+https://bitbucket.org/multicoreware/x265')
+source=('hg+http://hg.videolan.org/x265')
sha256sums=('SKIP')
pkgver() {
- cd x265
-
- echo "$(hg log -r. --template "{latesttag}").r$(hg log -r. --template "{latesttagdistance}").$(hg log -r. --template "{node|short}")"
-}
-
-prepare() {
- cd x265
-
- for d in 8 $([[ $CARCH == 'x86_64' ]] && echo "10 12"); do
- if [[ -d build-$d ]]; then
- rm -rf build-$d
- fi
- mkdir build-$d
- done
+ printf '%s.r%s.%s' "$(hg -R x265 log -r. --template '{latesttag}')" \
+ "$(hg -R x265 log -r. --template '{latesttagdistance}')" \
+ "$(hg -R x265 log -r. --template '{node|short}')"
}
build() {
- if [[ $CARCH == x86_64 ]]; then
-
- cd x265/build-12
-
- cmake ../source \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DHIGH_BIT_DEPTH='TRUE' \
- -DMAIN12='TRUE' \
- -DEXPORT_C_API='FALSE' \
- -DENABLE_CLI='FALSE' \
- -DENABLE_SHARED='FALSE'
- make
-
- cd ../build-10
-
- cmake ../source \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DHIGH_BIT_DEPTH='TRUE' \
- -DEXPORT_C_API='FALSE' \
- -DENABLE_CLI='FALSE' \
- -DENABLE_SHARED='FALSE'
- make
-
- cd ../build-8
-
- ln -s ../build-10/libx265.a libx265_main10.a
- ln -s ../build-12/libx265.a libx265_main12.a
-
- cmake ../source \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DENABLE_SHARED='TRUE' \
- -DENABLE_HDR10_PLUS='TRUE' \
- -DEXTRA_LIB='x265_main10.a;x265_main12.a' \
- -DEXTRA_LINK_FLAGS='-L.' \
- -DLINKED_10BIT='TRUE' \
- -DLINKED_12BIT='TRUE'
- make
-
- else
-
- cd x265/build-8
-
- cmake ../source \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DENABLE_SHARED='TRUE'
-
- fi
+ cmake -S x265/source -B build-12 \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DHIGH_BIT_DEPTH='ON' \
+ -DMAIN12='ON' \
+ -DEXPORT_C_API='OFF' \
+ -DENABLE_CLI='OFF' \
+ -DENABLE_SHARED='OFF' \
+ -Wno-dev
+ make -C build-12
+
+ cmake -S x265/source -B build-10 \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DHIGH_BIT_DEPTH='ON' \
+ -DEXPORT_C_API='OFF' \
+ -DENABLE_CLI='OFF' \
+ -DENABLE_SHARED='OFF' \
+ -Wno-dev
+ make -C build-10
+
+ cmake -S x265/source -B build \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DENABLE_SHARED='ON' \
+ -DENABLE_HDR10_PLUS='ON' \
+ -DEXTRA_LIB='x265_main10.a;x265_main12.a' \
+ -DEXTRA_LINK_FLAGS='-L.' \
+ -DLINKED_10BIT='ON' \
+ -DLINKED_12BIT='ON' \
+ -Wno-dev
+ ln -s ../build-10/libx265.a build/libx265_main10.a
+ ln -s ../build-12/libx265.a build/libx265_main12.a
+ make -C build
}
package() {
- cd x265/build-8
-
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="$pkgdir" install
}
-
-# vim: ts=2 sw=2 et:
diff --git a/libx265_main10-soname.patch b/libx265_main10-soname.patch
deleted file mode 100644
index 4761edb15507..000000000000
--- a/libx265_main10-soname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -rupN x265/source/CMakeLists.txt x265-10bit/source/CMakeLists.txt
---- x265/source/CMakeLists.txt 2015-06-11 09:46:35.227652244 +0200
-+++ x265-10bit/source/CMakeLists.txt 2015-06-11 09:55:15.561256669 +0200
-@@ -427,6 +427,7 @@ if(ENABLE_SHARED)
- set_target_properties(x265-shared PROPERTIES OUTPUT_NAME x265)
- endif()
- if(UNIX)
-+ set_target_properties(x265-shared PROPERTIES OUTPUT_NAME x265_main10)
- set_target_properties(x265-shared PROPERTIES VERSION ${X265_BUILD})
- if(APPLE)
- set_target_properties(x265-shared PROPERTIES MACOSX_RPATH 1)
diff --git a/libx265_main12-soname.patch b/libx265_main12-soname.patch
deleted file mode 100644
index 335366f9a720..000000000000
--- a/libx265_main12-soname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -rupN x265/source/CMakeLists.txt x265-10bit/source/CMakeLists.txt
---- x265/source/CMakeLists.txt 2015-06-11 09:46:35.227652244 +0200
-+++ x265-10bit/source/CMakeLists.txt 2015-06-11 09:55:15.561256669 +0200
-@@ -427,6 +427,7 @@ if(ENABLE_SHARED)
- set_target_properties(x265-shared PROPERTIES OUTPUT_NAME x265)
- endif()
- if(UNIX)
-+ set_target_properties(x265-shared PROPERTIES OUTPUT_NAME x265_main12)
- set_target_properties(x265-shared PROPERTIES VERSION ${X265_BUILD})
- if(APPLE)
- set_target_properties(x265-shared PROPERTIES MACOSX_RPATH 1)