summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2020-10-25 18:31:03 +1300
committerMorgenstern2020-10-25 18:31:03 +1300
commit6b19e9650454f379e53d2b0c9df8a571cb2596fe (patch)
treed43f13909cc2b2a052b69dc101b9025d427fec91
parentf726de810f224f86e7feb439f6a4b14c04cc4a6f (diff)
downloadaur-6b19e9650454f379e53d2b0c9df8a571cb2596fe.tar.gz
Remove srcdir references from PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9b841d97071..a97b18818888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = roundcubemail-plugin-twofactor-git
pkgdesc = Adds two-step verification (TOTP) to the Roundcube login process
- pkgver = r191.261d14e
+ pkgver = r193.fbeca4c
pkgrel = 1
url = https://github.com/alexandregz/twofactor_gauthenticator
install = roundcubemail-plugin-twofactor-git.install
arch = any
license = MIT
makedepends = git
- depends = roundcubemail>=0.9.5
replaces = roundcube-twofactor-git
source = roundcubemail-plugin-twofactor-git::git+https://github.com/alexandregz/twofactor_gauthenticator.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b8457e294546..093f6ebb19d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
-# Contributor: Philip Abernethy<chais.z3r0@gmail.com>
+# Contributor: Philip Abernethy <chais.z3r0@gmail.com>
pkgname=roundcubemail-plugin-twofactor-git
-pkgver=r191.261d14e
+pkgver=r193.fbeca4c
pkgrel=1
pkgdesc="Adds two-step verification (TOTP) to the Roundcube login process"
url="https://github.com/alexandregz/twofactor_gauthenticator"
arch=('any')
license=('MIT')
-depends=('roundcubemail>=0.9.5')
+#depends=('roundcubemail>=0.9.5')
makedepends=('git')
replaces=('roundcube-twofactor-git')
install=${pkgname}.install
@@ -16,7 +16,7 @@ source=("${pkgname}::git+https://github.com/alexandregz/twofactor_gauthenticator
sha512sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -25,8 +25,8 @@ pkgver() {
package() {
_instdir="${pkgdir}"/usr/share/webapps/roundcubemail/plugins/twofactor_gauthenticator
- install -dm755 "${_instdir}"/{localization,PHPGangsta}
- cd "${srcdir}"/${pkgname}
+ install -d "${_instdir}"/{localization,PHPGangsta}
+ cd "${pkgname}"
find . -type f -name '*php*' -exec install -m644 {} "${_instdir}"/{} \;
find . -type f -name '*js*' -exec install -m644 {} "${_instdir}"/{} \;
find . -type f -name '*inc' -exec install -m644 {} "${_instdir}"/{} \;