summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Saparelli2018-04-27 22:16:52 +1200
committerFélix Saparelli2018-04-27 22:27:27 +1200
commit6b2720246138c45d923c7e0ecac0f0b94396dc5a (patch)
tree0cde17510961d15e1ac7086aec34835fb113c835
downloadaur-6b2720246138c45d923c7e0ecac0f0b94396dc5a.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
-rw-r--r--zoho-docs.desktop10
-rw-r--r--zohodocs.sh4
5 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2cc55d26465
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = zoho-docs-bin
+ pkgdesc = Graphical application to sync files to/from Zoho Docs
+ pkgver = 1.9.2
+ pkgrel = 1
+ arch = x86_64
+ license = proprietary
+ source = https://www.zoho.com/docs/36925/ZohoDocs_x64.tar.gz
+ source = zoho-docs.desktop
+ sha512sums = 2c103bc33b96116132069c0a7ccdc17f3db87baf5d81b870829a4e8e0980ff352f4d5ca79dabc4083e18cff99364d75e9249522b0623276ae4e3af0bc49daa07
+ sha512sums = 98b2d2fefd783a838821577f997fe509f3d72e965851090bebbd31f34f10d9bf3c3aa9b4c81b9c1c2cf3f3c6a5610ec2df79e9f77a0b38ac7cc6801685f72c3a
+
+pkgname = zoho-docs-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f5267899177
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/*.tar*
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8baa07aa1cf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Félix Saparelli <aur@passcod.name>
+
+pkgname=zoho-docs-bin
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Graphical application to sync files to/from Zoho Docs"
+arch=('x86_64')
+url=""
+license=('proprietary')
+depends=()
+source=('https://www.zoho.com/docs/36925/ZohoDocs_x64.tar.gz'
+ 'zoho-docs.desktop'
+ 'zohodocs.sh')
+sha512sums=('2c103bc33b96116132069c0a7ccdc17f3db87baf5d81b870829a4e8e0980ff352f4d5ca79dabc4083e18cff99364d75e9249522b0623276ae4e3af0bc49daa07'
+ 'ff56d7461068689774d25209683d15804c5f186a611fb40f30bf7185e72061e1ce39464305da27b12d6f9e8ff21cb3b87ce377ef1bc7e981e17dfce25ecbfba0'
+ '3b5c6a2ea60b31aeaa3074827cdb2c42e9bbbcacbca8d55d6581297de15f5732650a32632bf73db3690ee0c19c1a88b21bada1b02781a19f02d6750c337428f7')
+
+build() {
+ cd "$srcdir/zohodocs"
+ rm *.desktop
+ #head .setup -n308 > setup.sh # to figure out what to do
+ tail .setup -n+310 | tar xz
+ rm .setup
+}
+
+package() {
+ install -d "$pkgdir"/{usr/{bin,share/applications},opt}
+ install -Dm644 "$srcdir/zoho-docs.desktop" "$pkgdir/usr/share/applications/"
+ install -Dm755 "$srcdir/zohodocs.sh" "$pkgdir/usr/bin/zohodocs"
+ cp -r "$srcdir/zohodocs" "$pkgdir/opt/"
+}
diff --git a/zoho-docs.desktop b/zoho-docs.desktop
new file mode 100644
index 000000000000..e2540a352abd
--- /dev/null
+++ b/zoho-docs.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Zoho Docs
+Comment=Sync documents to Zoho Docs
+Exec=/usr/bin/zohodocs
+Terminal=false
+Type=Application
+Icon=/opt/zohodocs/images/r1.png
+Categories=Network;FileTransfer;
+MimeType=application/x-zwriter-link;application/x-zsheet-link;application/x-zshow-link;
+StartupNotify=false
diff --git a/zohodocs.sh b/zohodocs.sh
new file mode 100644
index 000000000000..ad85dfaedefb
--- /dev/null
+++ b/zohodocs.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+BINPATH="/opt/zohodocs"
+export LD_LIBRARY_PATH="$BINPATH"
+exec "$BINPATH"/zohodocsd "$@"