summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordplusplus2022-01-30 18:52:21 -0800
committerdplusplus2022-01-30 18:52:34 -0800
commit6b7013ea95880edf136b23b5a192c4998d93c710 (patch)
tree053389895470501fd1ae0336f527c6d0037cdd48
parent0bf755ec2782bd1da7a1fe64d6305def65cb3405 (diff)
downloadaur-6b7013ea95880edf136b23b5a192c4998d93c710.tar.gz
Fix the tmux command when starting a new TShock instance, and set system user 'terraria' shell to bash (needed for tmux to work)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--tshock.sh8
-rw-r--r--tshock.sysusers2
4 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43fde79c61bc..6d0d89bb79b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tshock-bin
pkgdesc = A Terraria Server administration modification that runs on the open source TerrariaAPI.
pkgver = 4.5.12
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/Pryaxis/TShock
install = tshock.install
diff --git a/PKGBUILD b/PKGBUILD
index fafc6c073661..8a752be8ae7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=${_pkgname}-bin
pkgver=4.5.12
# Because of tag 4.2200 is 4.2.2.1228 and tag 4.2202 is 4.2.2.0224 epoch must be 1
epoch=1
-pkgrel=3
+pkgrel=4
pkgdesc="A Terraria Server administration modification that runs on the open source TerrariaAPI."
arch=("x86_64" "aarch64")
url="https://github.com/Pryaxis/TShock"
diff --git a/tshock.sh b/tshock.sh
index d05cb19caf0f..77635df972a0 100644
--- a/tshock.sh
+++ b/tshock.sh
@@ -59,12 +59,12 @@ TMUX_CONSOLE=tshock-console-${INSTANCE}
case "$1" in
start)
if tmux has-session -t ${TMUX_CONSOLE} &> /dev/null ; then
- echo "TShock instance '$INSTANCE' is already running"
+ echo "TShock instance '${INSTANCE}' is already running"
exit 1
else
- echo "starting '${INSTANCE}'"
- tmux new-session -d -s "${TMUX_CONSOLE}"
- mono --server --gc=sgen -O=all /srv/tshock/TerrariaServer.exe -port ${PORT} -logpath ${BASEDIR}/${INSTANCE} -worldpath ${WORLDDIR} -world ${WORLDDIR}/${WORLD}.wld -autocreate ${SIZE}
+ echo "Starting '${INSTANCE}'"
+ CMD="mono --server --gc=sgen -O=all /srv/tshock/TerrariaServer.exe -port ${PORT} -logpath ${BASEDIR}/${INSTANCE} -worldpath ${WORLDDIR} -world ${WORLDDIR}/${WORLD}.wld -autocreate ${SIZE}"
+ tmux new-session -d -s "${TMUX_CONSOLE}" "${CMD}"
if [ $? -gt 0 ]; then
echo "Could not start instance '${INSTANCE}'"
exit 1
diff --git a/tshock.sysusers b/tshock.sysusers
index 69add06d94f3..ab18691b95cc 100644
--- a/tshock.sysusers
+++ b/tshock.sysusers
@@ -1 +1 @@
-u terraria - "Terraria Server user" /var/lib/tshock
+u terraria - "Terraria Server user" /var/lib/tshock /bin/bash