summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-01-09 03:12:26 +0800
committerChocobo12018-01-09 03:12:26 +0800
commit6b83642bac90b2b455daf5d19fad322cf9bd8b99 (patch)
tree4d20b769361c8ee7b22c8ec02cf028149d3cce97
parent9ed4f6bdf0306141934bee87f65a9e4d665e8aec (diff)
downloadaur-6b83642bac90b2b455daf5d19fad322cf9bd8b99.tar.gz
upgpkg: butteraugli-git r33.g856a4da-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19093b59a439..6eff658713c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = butteraugli-git
pkgdesc = A tool for measuring perceived differences between images
- pkgver = 290e395
+ pkgver = r33.g856a4da
pkgrel = 1
- epoch = 1
url = https://github.com/google/butteraugli
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b48987805a3e..4e2ffa757948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=butteraugli-git
-pkgver=290e395
+pkgver=r33.g856a4da
pkgrel=1
-epoch=1
pkgdesc="A tool for measuring perceived differences between images"
arch=('i686' 'x86_64')
url="https://github.com/google/butteraugli"
@@ -19,7 +18,9 @@ sha256sums=('SKIP')
pkgver() {
cd "butteraugli"
- git describe --always
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
}
build() {