summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862021-02-27 00:00:32 +0100
committersatcom8862021-02-27 00:00:32 +0100
commit6ba105447c31e1b95aa6f2b1c54bf56057dc2a62 (patch)
tree6d8e98b916d5d8a6417ccf9d97eb0a20d9c421d7
parent6f046b355f1738fc1fdaf8a1b46e5d73204a729c (diff)
downloadaur-6ba105447c31e1b95aa6f2b1c54bf56057dc2a62.tar.gz
Cleaned up the PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64522c62022a..92030311be67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = boinc-manager-web-git
pkgdesc = Web Client for BOINC
pkgver = r163.24e3847
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/adamradocz/boinc-manager
arch = x86_64
arch = aarch64
license = GPL3
makedepends = dotnet-sdk>=3
- makedepends = yarn
makedepends = git
depends = aspnet-runtime
source = boinc-manager::git+https://github.com/adamradocz/boinc-manager
diff --git a/PKGBUILD b/PKGBUILD
index 0c3a35ea5ec0..f5b2a2eb9bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=(boinc-manager-web-git)
pkgver=r163.24e3847
-pkgrel=2
+pkgrel=3
pkgdesc='Web Client for BOINC'
arch=('x86_64' 'aarch64')
url='https://github.com/adamradocz/boinc-manager'
license=('GPL3')
-makedepends=('dotnet-sdk>=3' 'yarn' 'git')
+makedepends=('dotnet-sdk>=3' 'git')
depends=('aspnet-runtime')
source=("boinc-manager::git+https://github.com/adamradocz/boinc-manager"
'boinc-manager-web.service'
@@ -25,22 +25,12 @@ pkgver() {
build(){
cd boinc-manager/BoincManagerWeb
-
- # yarn install
+ # Fetch dependencies
dotnet restore BoincManagerWeb.csproj
-
# Disable dotnet telemetry
export DOTNET_CLI_TELEMETRY_OPTOUT=1
-
+ # Build the thing
dotnet publish "BoincManagerWeb.csproj" -c Release --no-restore -o "$PWD/publish"
- #dotnet build --configuration Release
- # Ideally, this would be run in package() with the --output variable pointing
- # to "$pkgdir"/usr/lib/jellyfin, but this step fails in fakeroot.
- # The makepkg output looks like
- # Restore completed in 56.84 ms for /aur/jellyfin-git/src/jellyfin/Jellyfin.Server/Jellyfin.Server.csproj.
- # ==> ERROR: A failure occurred in package().
- # without indicating any sort
- #dotnet publish --configuration Release --output "$PWD"/publish
# Clean up the runtimes folder (keep linux-*)
rm -rfv publish/runtimes/{alpine-*,osx*,tizen-*,win*}
}