summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetalgamer2015-08-09 13:40:14 +0200
committermetalgamer2015-08-09 13:40:14 +0200
commit6ba19a55a1e97d763944e617c902a8baca5b5cdb (patch)
treec119891f006c6e6202fa54095227c058fc579be4
downloadaur-6ba19a55a1e97d763944e617c902a8baca5b5cdb.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE.TXT54
-rw-r--r--PKGBUILD37
-rwxr-xr-xyuicompressor.sh3
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90fb1627ac4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yuicompressor
+ pkgdesc = CSS and Javascript compressor
+ pkgver = 2.4.8
+ pkgrel = 2
+ url = http://developer.yahoo.com/yui/compressor/
+ arch = any
+ license = BSD
+ depends = java-runtime
+ source = https://github.com/yui/yuicompressor/releases/download/v2.4.8/yuicompressor-2.4.8.zip
+ source = yuicompressor.sh
+ source = https://raw.github.com/yui/yuicompressor/master/LICENSE.TXT
+ sha1sums = 178e265570c8161e8074c7ca19896abb05e76c1f
+ sha1sums = 1d261a0365c2d15f1be1c1f06bb1df83f965d091
+ sha1sums = 93278e24065a4595d1804eb6ed537258ff94c08c
+
+pkgname = yuicompressor
+
diff --git a/LICENSE.TXT b/LICENSE.TXT
new file mode 100644
index 000000000000..8a1c7a1af2ee
--- /dev/null
+++ b/LICENSE.TXT
@@ -0,0 +1,54 @@
+YUI Compressor Copyright License Agreement (BSD License)
+
+Copyright (c) 2013, Yahoo! Inc.
+All rights reserved.
+
+Redistribution and use of this software in source and binary forms,
+with or without modification, are permitted provided that the following
+conditions are met:
+
+* Redistributions of source code must retain the above
+ copyright notice, this list of conditions and the
+ following disclaimer.
+
+* Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the
+ following disclaimer in the documentation and/or other
+ materials provided with the distribution.
+
+* Neither the name of Yahoo! Inc. nor the names of its
+ contributors may be used to endorse or promote products
+ derived from this software without specific prior
+ written permission of Yahoo! Inc.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+This software also requires access to software from the following sources:
+
+The Jarg Library v 1.0 ( http://jargs.sourceforge.net/ ) is available
+under a BSD License � Copyright (c) 2001-2003 Steve Purcell,
+Copyright (c) 2002 Vidar Holen, Copyright (c) 2002 Michal Ceresna and
+Copyright (c) 2005 Ewan Mellor.
+
+The Rhino Library ( http://www.mozilla.org/rhino/ ) is dually available
+under an MPL 1.1/GPL 2.0 license, with portions subject to a BSD license.
+
+Additionally, this software contains modified versions of the following
+component files from the Rhino Library:
+
+[org/mozilla/javascript/Decompiler.java]
+[org/mozilla/javascript/Parser.java]
+[org/mozilla/javascript/Token.java]
+[org/mozilla/javascript/TokenStream.java]
+
+The modified versions of these files are distributed under the MPL v 1.1
+( http://www.mozilla.org/MPL/MPL-1.1.html )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a5792b37d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dennis Fink <metalgamer@c3l.lu>
+# Maintainer: Oleg Rakhmanov <orakhmanov [at] gmail [dot] com>
+# Contributor: Anntoin Wilkinson <anntoin gmail com>
+# Contributor: Vladimir Ermakov <vooon341@gmail.com>
+# Contributor: Peter A. Shevtsov <pshevtsov at severusweb dot ru>
+
+pkgname=yuicompressor
+pkgver=2.4.8
+pkgrel=2
+pkgdesc="CSS and Javascript compressor"
+arch=("any")
+url="http://developer.yahoo.com/yui/compressor/"
+license=("BSD")
+depends=("java-runtime")
+source=("https://github.com/yui/yuicompressor/releases/download/v${pkgver}/yuicompressor-${pkgver}.zip"
+ "yuicompressor.sh"
+ 'https://raw.github.com/yui/yuicompressor/master/LICENSE.TXT')
+
+sha1sums=('178e265570c8161e8074c7ca19896abb05e76c1f'
+ '1d261a0365c2d15f1be1c1f06bb1df83f965d091'
+ '93278e24065a4595d1804eb6ed537258ff94c08c')
+
+package() {
+ sed -i "s|x\.y\.z|${pkgver}|" "${pkgname}.sh"
+
+
+ install -D -m644 "${srcdir}/${pkgname}-${pkgver}.jar" \
+ "${pkgdir}/usr/share/java/${pkgname}-${pkgver}.jar"
+ install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/yuicompressor"
+
+ install -D -m644 "${srcdir}/LICENSE.TXT" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.TXT"
+ ln -s "yuicompressor" "${pkgdir}/usr/bin/yui-compressor"
+ ln -s "${pkgname}-${pkgver}.jar" "${pkgdir}/usr/share/java/${pkgname}.jar"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/yuicompressor.sh b/yuicompressor.sh
new file mode 100755
index 000000000000..a80d7eedf049
--- /dev/null
+++ b/yuicompressor.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+"$JAVA_HOME/bin/java" -jar /usr/share/java/yuicompressor-x.y.z.jar "$@"