summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2018-03-09 15:00:04 -0500
committerKevin MacMartin2018-03-09 15:00:04 -0500
commit6bba43ad0871218a486e36dcae144b5c75b092aa (patch)
tree00bf5ba6b5fc818d93a554e12934658a7b8b5ba0
parentbb0c83b50e75b00cf7c58381ce926b6ced2ddeec (diff)
downloadaur-6bba43ad0871218a486e36dcae144b5c75b092aa.tar.gz
Clean up the PKGBUILD and add a conflict with the python-based cheat-git package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7dc1eca849b..244c892d7d0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Mon May 1 21:33:16 UTC 2017
+# Fri Mar 9 19:59:59 UTC 2018
pkgbase = cheat-bash-git
pkgdesc = A Bash reimplementation of a command line tool to create and view interactive cheatsheets
pkgver = 20170501.r36.a9e6764
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jahendrie/cheat
arch = any
license = GPL3
makedepends = git
depends = bash
- source = git://github.com/jahendrie/cheat.git#branch=master
+ conflicts = cheat-git
+ source = git+https://github.com/jahendrie/cheat
sha512sums = SKIP
pkgname = cheat-bash-git
diff --git a/PKGBUILD b/PKGBUILD
index 22491fbae365..439573379f7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
_pkgname=cheat
-pkgname=${_pkgname}-bash-git
+pkgname=$_pkgname-bash-git
pkgver=20170501.r36.a9e6764
-pkgrel=1
-pkgdesc="A Bash reimplementation of a command line tool to create and view interactive cheatsheets"
-url="https://github.com/jahendrie/${_pkgname}"
+pkgrel=2
+pkgdesc='A Bash reimplementation of a command line tool to create and view interactive cheatsheets'
+url='https://github.com/jahendrie/cheat'
license=('GPL3')
arch=('any')
depends=('bash')
makedepends=('git')
-source=("git://github.com/jahendrie/${_pkgname}.git#branch=master")
+source=("git+$url")
sha512sums=('SKIP')
+conflicts=("$_pkgname-git")
pkgver() {
- cd $_pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $_pkgname
- install -Dm755 src/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 doc/${_pkgname}.1.gz "${pkgdir}/usr/share/man/man1/${_pkgname}.1.gz"
- install -d "${pkgdir}//usr/share/${_pkgname}"
- cp -R data/* "${pkgdir}/usr/share/${_pkgname}/"
+ cd $_pkgname
+ install -Dm755 src/$_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 doc/$_pkgname.1.gz "$pkgdir/usr/share/man/man1/$_pkgname.1.gz"
+ install -d "$pkgdir//usr/share/$_pkgname"
+ cp -R data/* "$pkgdir/usr/share/$_pkgname/"
}