summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2022-11-28 16:48:17 -0500
committerTony Lambiris2022-11-28 16:48:17 -0500
commit6bdeb9f067a266b30b3f4ba002d0c63afaa369a8 (patch)
treed344fa0d59116269d169d63cc8f6ba0a995e3ad7
parent5445a600bb633b04a5b0724496d14f9ba5564444 (diff)
downloadaur-6bdeb9f067a266b30b3f4ba002d0c63afaa369a8.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mkinitcpio.patch24
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46ad0e5cea34..d53b72b0a2b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
- pkgver = 1.1.23.r0.gb9b6342
+ pkgver = 1.1.24.r1.g437d6ba
pkgrel = 1
url = https://github.com/pop-os/system76-power
arch = any
@@ -17,6 +17,6 @@ pkgbase = system76-power-git
source = mkinitcpio.patch
sha256sums = SKIP
sha256sums = 35af9e2c62deee200ac550f9390a3a43811d3336e1833e577deeda06482ad488
- sha256sums = fefd4bd1c173cca2aafd3d5f03af20b9cfc5553f9a53f510a12d565cc90fe7ba
+ sha256sums = bae03d96faea0f7ea80cb1cc5d4f2f97804509db378aaacb3e1d08cd38e05765
pkgname = system76-power-git
diff --git a/PKGBUILD b/PKGBUILD
index 66eab7372d3a..0dd91a0fefde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=system76-power-git
-pkgver=1.1.23.r0.gb9b6342
+pkgver=1.1.24.r1.g437d6ba
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -16,7 +16,7 @@ source=("${pkgname}::git+https://github.com/pop-os/system76-power.git"
"mkinitcpio.patch")
sha256sums=('SKIP'
'35af9e2c62deee200ac550f9390a3a43811d3336e1833e577deeda06482ad488'
- 'fefd4bd1c173cca2aafd3d5f03af20b9cfc5553f9a53f510a12d565cc90fe7ba')
+ 'bae03d96faea0f7ea80cb1cc5d4f2f97804509db378aaacb3e1d08cd38e05765')
pkgver() {
cd "${srcdir}/${pkgname}"
diff --git a/mkinitcpio.patch b/mkinitcpio.patch
index 8952285be491..e70bce44fb34 100644
--- a/mkinitcpio.patch
+++ b/mkinitcpio.patch
@@ -1,22 +1,28 @@
diff --git a/src/graphics.rs b/src/graphics.rs
-index ebdd9b6..7223a6e 100644
+index 4fecb8b..5974717 100644
--- a/src/graphics.rs
+++ b/src/graphics.rs
-@@ -80,7 +80,7 @@ pub enum GraphicsDeviceError {
+@@ -95,7 +95,7 @@ const EXTERNAL_DISPLAY_REQUIRES_NVIDIA: &[&str] = &[
+ ];
+
+ const SYSTEMCTL_CMD: &str = "systemctl";
+-const UPDATE_INITRAMFS_CMD: &str = "update-initramfs";
++const UPDATE_INITRAMFS_CMD: &str = "mkinitcpio";
+
+ #[derive(Debug, thiserror::Error)]
+ pub enum GraphicsDeviceError {
+@@ -127,7 +127,7 @@ pub enum GraphicsDeviceError {
SysFs(io::Error),
#[error("failed to unbind {} on PCI driver {}: {}", func, driver, why)]
Unbind { func: String, driver: String, why: io::Error },
- #[error("update-initramfs failed with {} status", _0)]
-+ #[error("initramfs update failed with {} status", _0)]
++ #[error("mkinitcpio failed with {} status", _0)]
UpdateInitramfs(ExitStatus),
- }
-
-@@ -427,9 +427,9 @@ impl Graphics {
- }
+ #[error("failed to access Xserver config: {}", _0)]
+ XserverConf(io::Error),
+@@ -535,7 +535,7 @@ impl Graphics {
log::info!("Updating initramfs");
-- const UPDATE_INITRAMFS_CMD: &str = "update-initramfs";
-+ const UPDATE_INITRAMFS_CMD: &str = "mkinitcpio";
let status = process::Command::new(UPDATE_INITRAMFS_CMD)
- .arg("-u")
+ .arg("-P")