summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2022-09-06 00:22:43 -0700
committerTechcable2022-09-06 00:24:15 -0700
commit6beb1cb1c4f451fce721b34b445d1bac5af05121 (patch)
treee1d167113ceb0d4b6687c2d46a35fc5522f78e7a
parent87fa99ccddcb4473bc0df5647b461af95ca93f4f (diff)
downloadaur-6beb1cb1c4f451fce721b34b445d1bac5af05121.tar.gz
Delete local Zig cache created for test run.
I see no reason for it to live. <evil laugh>
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dae8db3a9c8..17165e1c16ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -83,12 +83,13 @@ check() {
# For these hello world examples (in a frequently updated package), this is very wasteful.
#
# Right now there is no way to disable the cache (see Zig issue #12317)
- # Instead we shove everything in a local directory
+ # Instead we shove everything in a local directory and delete it
cache_dir="${srcdir}/zig-cache"
cd "${srcdir}/zig-linux-${CARCH}-${pkgver//_/-}";
echo "Running Zig Hello World"
./zig run --cache-dir "$cache_dir" --global-cache-dir "$cache_dir" "$hello_file"
./zig test --cache-dir "$cache_dir" --global-cache-dir "$cache_dir" "$hello_file"
+ rm -rf "$cache_dir"
rm -rf "$cache_dir";
local missing_docs=();
# Zig has had long-running issues with the location