summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-24 11:14:28 -0600
committerMark Wagie2024-03-24 11:14:28 -0600
commit6c04fc09a1fc702cd8c30fe3a8f7a5b0310c5e51 (patch)
treee38dc0f7c7b723b512d7d427213186048ca05533
parent478f63a1d2480df7bdb15d65076932fbde7aff5a (diff)
downloadaur-6c04fc09a1fc702cd8c30fe3a8f7a5b0310c5e51.tar.gz
0.9.9.3, updated
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD77
-rw-r--r--meteo.install12
4 files changed, 50 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eac509885ab..801c77cca258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = meteo
- pkgdesc = Meteo es un proyecto de software libre que recopila datos meteorológicos para Radit.
- pkgver = 1.0.2+r2.ea7996c
- pkgrel = 1
- url = http://www.radit.org/net
- install = meteo.install
- arch = any
- license = GPL v3
+ pkgdesc = A forecast application using OpenWeatherMap API
+ pkgver = 0.9.9.3
+ pkgrel = 2
+ url = https://gitlab.com/bitseater/meteo
+ arch = x86_64
+ license = GPL-3.0-or-later
+ checkdepends = appstream
makedepends = git
- depends = qt4
- source = meteo::git+https://github.com/jfperini/meteo.git
- md5sums = SKIP
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = libayatana-appindicator
+ depends = webkit2gtk
+ conflicts = meteo-gtk
+ replaces = meteo-gtk
+ source = git+https://gitlab.com/bitseater/meteo.git#commit=5d8501911faed913036609e8ae7dfb2b35d76f4a?signed
+ validpgpkeys = 900E41F44EFF4B6D696EB80AE6BDC743AED36483
+ sha256sums = SKIP
pkgname = meteo
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 6725c1a6b423..b83951f65eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,37 @@
-# Maintainer: jfperini <@jfperini>
-# Contributor: jfperini <@jfperini>
-
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=meteo
-pkgver=1.0.2+r2.ea7996c
-pkgrel=1
-pkgdesc="Meteo es un proyecto de software libre que recopila datos meteorológicos para Radit."
-url="http://www.radit.org/net"
-arch=('any')
-license=('GPL v3')
-install=meteo.install
-depends=('qt4')
-makedepends=('git')
-# provides=('')
-# conflicts=('')
-source=("$pkgname"::'git+https://github.com/jfperini/meteo.git')
-# Because the sources are not static, skip Git checksum:
-md5sums=('SKIP')
+pkgver=0.9.9.3
+pkgrel=2
+pkgdesc="A forecast application using OpenWeatherMap API"
+arch=('x86_64')
+url="https://gitlab.com/bitseater/meteo"
+license=('GPL-3.0-or-later')
+depends=('gtk3' 'libayatana-appindicator' 'webkit2gtk')
+makedepends=('git' 'meson' 'vala')
+checkdepends=('appstream')
+conflicts=('meteo-gtk')
+replaces=('meteo-gtk')
+_commit=5d8501911faed913036609e8ae7dfb2b35d76f4a # tags/0.9.9.3^0
+source=("git+https://gitlab.com/bitseater/meteo.git#commit=${_commit}?signed")
+sha256sums=('SKIP')
+validpgpkeys=('900E41F44EFF4B6D696EB80AE6BDC743AED36483') # Carlos Suárez <bitseater@gmail.com>
pkgver() {
-
- cd "$srcdir/$pkgname"
-
- # Use the tag of the last commit
- printf "1.0.2+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-
+ cd "$pkgname"
+ git describe --tags | sed 's/-/+/g'
}
-
-build()
-{
-
- cd "$srcdir/$pkgname/src"
-
- msg2 " -> Build program..."
- qmake-qt4 $pkgname.pro
- make
-
+build() {
+ arch-meson "$pkgname" build
+ meson compile -C build
}
+check() {
+ meson test -C build --print-errorlogs || :
+}
package() {
+ meson install -C build --destdir "$pkgdir"
- cd "$srcdir/$pkgname"
-
- rm -rf {.git,.gitignore,CONTRIBUTORS,COPYING,CREDITS,LICENSE.txt,README.md}
-
- msg2 " -> Installing program..."
- install -d $pkgdir/{opt/radit,usr/bin}
- cp -a "./LinuxDesktop/$pkgname" "$pkgdir/opt/radit"
- cp -u "./launcher/$pkgname" "$pkgdir/usr/bin"
-
- chmod -R 775 $pkgdir/opt/radit/$pkgname
-
- install -Dm644 "./launcher/$pkgname.svg" "$pkgdir/usr/share/pixmaps/$pkgname.svg"
- install -Dm644 "./launcher/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- # chmod -R ugo+rX "$pkgdir/opt"
-
+ ln -s /usr/bin/com.gitlab.bitseater.meteo "$pkgdir/usr/bin/$pkgname"
}
-
-# vim: ts=2 sw=2 et: \ No newline at end of file
diff --git a/meteo.install b/meteo.install
deleted file mode 100644
index 21f9139b41d1..000000000000
--- a/meteo.install
+++ /dev/null
@@ -1,12 +0,0 @@
-
- post_upgrade(){
-
- echo ":::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::"
-
- echo "Ejecutar nuevamenete el script: https://github.com/jfperini/radit/blob/master/radit.sh"
-
- echo ":::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::"
-
- echo "Gracias por actualizar Radit!"
-
- } \ No newline at end of file