summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoël Krähemann2019-11-28 08:28:33 +0000
committerJoël Krähemann2019-11-28 08:28:33 +0000
commit6c090a9d6baecbd0287a04961f287b929d1f8bc7 (patch)
tree60553446d90e296cced54667eeddc5731871ce3a
parentbbd350da478e53a5e03bb3370dac6985247eed54 (diff)
downloadaur-6c090a9d6baecbd0287a04961f287b929d1f8bc7.tar.gz
new release v1.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--libinstpatch-cmake-fixes.patch53
3 files changed, 63 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c5670f7ad7f..4cd47cdf0ba7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libinstpatch
pkgdesc = Instrument patch library
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = http://swamiproject.org
arch = x86_64
@@ -10,8 +10,10 @@ pkgbase = libinstpatch
makedepends = python3
depends = glib2
depends = libsndfile
- source = https://download.savannah.gnu.org/releases/gsequencer/1.4.x/libinstpatch-1.0.0+svn386.tar.bz2
- md5sums = 3e90da59e1d088ff9dbb270a1349cd99
+ source = libinstpatch-1.1.0.tar.gz::https://github.com/swami/libinstpatch/archive/v1.1.0.tar.gz
+ source = libinstpatch-cmake-fixes.patch
+ md5sums = 707ac830039f9cfa1686f213c7a03724
+ md5sums = 4cccbb5ff98cb9151548cde16166044e
pkgname = libinstpatch
diff --git a/PKGBUILD b/PKGBUILD
index 8815a474dcd8..a85471168b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,8 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=libinstpatch
-pkgver=1.0.0
-pkgsvnver=+svn386
+pkgver=1.1.0
pkgrel=1
-epoch=
pkgdesc="Instrument patch library"
arch=('x86_64' 'i386')
url="http://swamiproject.org"
@@ -25,20 +23,21 @@ backup=()
options=()
install=
changelog=
-source=("https://download.savannah.gnu.org/releases/gsequencer/1.4.x/$pkgname-$pkgver$pkgsvnver.tar.bz2")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/swami/libinstpatch/archive/v$pkgver.tar.gz" libinstpatch-cmake-fixes.patch)
noextract=()
-md5sums=('3e90da59e1d088ff9dbb270a1349cd99')
+md5sums=('707ac830039f9cfa1686f213c7a03724' '4cccbb5ff98cb9151548cde16166044e')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
+ patch -p1 --input=${srcdir}/libinstpatch-cmake-fixes.patch
}
build() {
cd "$pkgname-$pkgver"
mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DINCLUDE_INSTALL_DIR=/usr/include -DLIB_INSTALL_DIR=/usr/lib ..
make
}
diff --git a/libinstpatch-cmake-fixes.patch b/libinstpatch-cmake-fixes.patch
new file mode 100644
index 000000000000..9a3130c4eb66
--- /dev/null
+++ b/libinstpatch-cmake-fixes.patch
@@ -0,0 +1,53 @@
+Index: libinstpatch-1.1.0/CMakeLists.txt
+===================================================================
+--- libinstpatch-1.1.0.orig/CMakeLists.txt
++++ libinstpatch-1.1.0/CMakeLists.txt
+@@ -176,19 +176,19 @@ set (INSTPATCH_INSTALL_TARGET "libinstpa
+ # pkg-config support
+ if ( UNIX OR MINGW OR WIN32)
+ set ( prefix "${CMAKE_INSTALL_PREFIX}" )
+- set ( exec_prefix "\${prefix}" )
+- set ( libdir "\${exec_prefix}/${LIB_INSTALL_DIR}${LIB_SUFFIX}" )
+- set ( includedir "\${prefix}/${INCLUDE_INSTALL_DIR}/${INSTPATCH_INSTALL_TARGET}" )
++ set ( exec_prefix "${CMAKE_INSTALL_PREFIX}" )
++ set ( libdir "${LIB_INSTALL_DIR}" )
++ set ( includedir "${INCLUDE_INSTALL_DIR}/${INSTPATCH_INSTALL_TARGET}" )
+ # stamp library name with version current value (for Windows only)
+ if(MINGW OR WIN32)
+ set ( lib_output_name ${INSTPATCH_INSTALL_TARGET} )
+ else(MINGW OR WIN32)
+- set ( lib_output_name instpatch )
++ set ( lib_output_name instpatch-1.0 )
+ endif(MINGW OR WIN32)
+ configure_file ( libinstpatch-1.0.pc.in
+ ${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc IMMEDIATE @ONLY )
+ install ( FILES ${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc
+- DESTINATION ${LIB_INSTALL_DIR}${LIB_SUFFIX}/pkgconfig )
++ DESTINATION ${LIB_INSTALL_DIR}/pkgconfig )
+ endif ( UNIX OR MINGW OR WIN32)
+
+ # Extra targets for Unix build environments
+Index: libinstpatch-1.1.0/libinstpatch/CMakeLists.txt
+===================================================================
+--- libinstpatch-1.1.0.orig/libinstpatch/CMakeLists.txt
++++ libinstpatch-1.1.0/libinstpatch/CMakeLists.txt
+@@ -353,7 +353,7 @@ else( MINGW OR WIN32 )
+ set_target_properties ( libinstpatch
+ PROPERTIES
+ PREFIX ""
+- OUTPUT_NAME "libinstpatch"
++ OUTPUT_NAME "libinstpatch-1.0"
+ VERSION ${LIB_VERSION_INFO}
+ SOVERSION ${LIB_VERSION_CURRENT}
+ )
+@@ -366,8 +366,8 @@ endif ( IPATCH_CPPFLAGS )
+
+ install ( TARGETS libinstpatch
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+- LIBRARY DESTINATION ${LIB_INSTALL_DIR}${LIB_SUFFIX}
+- ARCHIVE DESTINATION ${LIB_INSTALL_DIR}${LIB_SUFFIX}
++ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
++ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+ FRAMEWORK DESTINATION ${FRAMEWORK_INSTALL_DIR}
+ BUNDLE DESTINATION ${BUNDLE_INSTALL_DIR}
+ )