summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElizabeth Harmon2022-06-01 13:06:11 +0100
committerElizabeth Harmon2022-06-01 13:06:11 +0100
commit6c1ce50332bb77c0ae107214f92a66e5824792bc (patch)
treec13212b99bb257eb5d9dbbc06ade171498510789
downloadaur-6c1ce50332bb77c0ae107214f92a66e5824792bc.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--nerolinux.install24
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e74c0dffd1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerolinux4
+ pkgdesc = Nero Burning ROM for linux (legacy version)
+ pkgver = 4.0.0.0b
+ pkgrel = 2
+ url = http://www.nero.com
+ install = nerolinux.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ provides = nerolinux
+ conflicts = nerolinux
+ source = nerolinux-4.0.0.0b-x86.rpm::http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86.rpm
+ md5sums = f49f49c588729c2afdbecb546d9b6041
+ depends_i686 = gtk2
+ depends_i686 = pangox-compat
+ depends_x86_64 = lib32-gtk2
+ depends_x86_64 = lib32-pangox-compat
+
+pkgname = nerolinux4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed2b05c7d16f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: BethHarmon <BethOliviaHarmon at gmail dot com>
+# Created from https://aur.archlinux.org/packages/nerolinux3
+
+pkgname=nerolinux4
+pkgver=4.0.0.0b
+pkgrel=2
+pkgdesc="Nero Burning ROM for linux (legacy version)"
+url="http://www.nero.com"
+license=('custom')
+depends_i686=('gtk2' 'pangox-compat')
+depends_x86_64=('lib32-gtk2' 'lib32-pangox-compat')
+conflicts=('nerolinux')
+provides=('nerolinux')
+arch=('i686' 'x86_64')
+source=("nerolinux-${pkgver}-x86.rpm"::'http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86.rpm')
+md5sums=('f49f49c588729c2afdbecb546d9b6041')
+install=nerolinux.install
+
+prepare() {
+ cd "$srcdir"
+ chmod a+rx -R *
+ find . -type f -exec chmod -x \{\} \;
+ chmod +x usr/bin/{nero,nerocmd}
+}
+
+package() {
+ cd "$pkgdir"
+ mv "${srcdir}"/* .
+ mkdir -p usr/share/licenses/nerolinux
+ mv usr/share/doc/nero/EULA* usr/share/licenses/nerolinux
+}
diff --git a/nerolinux.install b/nerolinux.install
new file mode 100644
index 000000000000..b422c73fdb2b
--- /dev/null
+++ b/nerolinux.install
@@ -0,0 +1,24 @@
+# arg 1: the new package version
+post_install() {
+ echo "For Nero to be able to detect CD/DVD drives,"
+ echo "add yourself to the 'optical' group."
+ echo "Also make sure sg module is loaded."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "For Nero to be able to detect CD/DVD drives,"
+ echo "add yourself to the 'optical' group."
+ echo "Also make sure sg module is loaded."
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*