summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortocic2022-09-07 11:43:41 +0300
committertocic2022-09-07 11:43:41 +0300
commit6c6ed3a925404a3063b52ee7433d62169dfa349b (patch)
tree0eeb1205d7188b9e38a54892a3b3136ab4e94c5f
parent5def21632ddc64450dab46543b49176280ce34a5 (diff)
downloadaur-6c6ed3a925404a3063b52ee7433d62169dfa349b.tar.gz
Remove pkgver variable from source filename
Fixes the "No such file or directory" error if pkgver() updates the variable.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD10
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 782c87e4ae30..6fde83ae1b73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-pkgbase = thor-git
- pkgdesc = SFML Extension with various game programming features, like particles, animations, vector operations
- pkgver = 2.0.r24.g3e320cb
- pkgrel = 1
- url = https://bromeon.ch/libraries/thor
- arch = x86_64
- license = ZLIB
- makedepends = cmake
- makedepends = git
- depends = sfml
- provides = thor
- conflicts = thor
- source = thor-git-2.0.r24.g3e320cb::git+https://github.com/Bromeon/Thor.git#branch=master
- source = fix_cmake_module_path.patch
- b2sums = SKIP
- b2sums = b1f082ce989d78abb14ad4615b1babce229f3e245409cbb820bdfd7693e9870ec86a5a586908a5b0d50576d67dd49c585928cf3f4bc94510d9615af7b64c9009
-
-pkgname = thor-git
+pkgbase = thor-git
+ pkgdesc = SFML Extension with various game programming features, like particles, animations, vector operations
+ pkgver = 2.0.r24.g3e320cb
+ pkgrel = 2
+ url = https://bromeon.ch/libraries/thor
+ arch = x86_64
+ license = ZLIB
+ makedepends = cmake
+ makedepends = git
+ depends = sfml
+ provides = thor
+ conflicts = thor
+ source = thor-git::git+https://github.com/Bromeon/Thor.git#branch=master
+ source = fix_cmake_module_path.patch
+ b2sums = SKIP
+ b2sums = b1f082ce989d78abb14ad4615b1babce229f3e245409cbb820bdfd7693e9870ec86a5a586908a5b0d50576d67dd49c585928cf3f4bc94510d9615af7b64c9009
+
+pkgname = thor-git
diff --git a/PKGBUILD b/PKGBUILD
index 6526cb4e42e5..522443743ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=thor-git
pkgver=2.0.r24.g3e320cb
-pkgrel=1
+pkgrel=2
pkgdesc="SFML Extension with various game programming features,
like particles, animations, vector operations"
arch=("x86_64")
@@ -12,25 +12,25 @@ depends=("sfml")
makedepends=("cmake" "git")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname}-${pkgver}::git+https://github.com/Bromeon/Thor.git#branch=master"
+source=("${pkgname}::git+https://github.com/Bromeon/Thor.git#branch=master"
"fix_cmake_module_path.patch")
b2sums=("SKIP"
"b1f082ce989d78abb14ad4615b1babce229f3e245409cbb820bdfd7693e9870ec86a5a586908a5b0d50576d67dd49c585928cf3f4bc94510d9615af7b64c9009")
pkgver() {
printf "%s" \
- $(git -C "${pkgname}-${pkgver}" describe --long --tags \
+ $(git -C "${pkgname}" describe --long --tags \
| sed "s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g")
}
prepare() {
patch --forward --strip=1 \
- --directory="${pkgname}-${pkgver}" \
+ --directory="${pkgname}" \
--input="${srcdir}/fix_cmake_module_path.patch"
}
build() {
- cmake -B "build/" -S "${pkgname}-${pkgver}" \
+ cmake -B "build/" -S "${pkgname}" \
-D THOR_BUILD_DOC:BOOL="OFF" \
-D THOR_BUILD_EXAMPLES:BOOL="OFF" \
-D THOR_SHARED_LIBS:BOOL="ON" \