summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkostyalamer2020-10-09 22:45:50 +0300
committerkostyalamer2020-10-09 22:45:50 +0300
commit6c7bcbfbcbb6396d0c7e04a99c3f94cf1c3f9fbb (patch)
treec2b9fc19dea395703ede6b255dbf58762ef5c51e
downloadaur-6c7bcbfbcbb6396d0c7e04a99c3f94cf1c3f9fbb.tar.gz
first build
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f3a34c69e20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = icedisk
+ pkgdesc = Special script for IceArch distro to cfdisk and formating partitions
+ pkgver = 0.1
+ pkgrel = 2
+ url = https://icearch.forumotion.eu/
+ arch = x86_64
+ license = GPL2
+ depends = coreutils
+ depends = grep
+ depends = gawk
+ depends = bc
+ depends = sed
+ depends = util-linux
+ depends = dialog
+ depends = reiserfsprogs
+ depends = exfat-utils
+ depends = ntfs-3g
+ depends = xfsprogs
+ depends = filesystem
+ depends = gptfdisk
+ source = http://altlinuxclub.ru/arhiv/icedisk-0.1.tar.gz
+ md5sums = 8be072e2f4a51adf2b1fabef327be852
+
+pkgname = icedisk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9102ecf3096
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: kostyalamer < kostyalamer@yandex.ru >
+# Contributor: kostyalamer
+pkgname=icedisk
+pkgver=0.1
+pkgrel=2
+pkgdesc="Special script for IceArch distro to cfdisk and formating partitions "
+arch=('x86_64')
+url="https://icearch.forumotion.eu/"
+license=('GPL2')
+
+depends=(
+ 'coreutils' 'grep' 'gawk' 'bc' 'sed' 'util-linux' 'dialog'
+ 'reiserfsprogs' 'exfat-utils' 'ntfs-3g' 'xfsprogs' 'filesystem' 'gptfdisk'
+)
+
+source=("http://altlinuxclub.ru/arhiv/${pkgname}-${pkgver}.tar.gz")
+md5sums=('8be072e2f4a51adf2b1fabef327be852')
+
+build() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+cat > $pkgname.desktop <<@@@
+[Desktop Entry]
+Type=Application
+Name=IceDisk
+Icon=/usr/share/icewm/icons/save_32x32.png
+TryExec=icedisk
+Exec=icedisk
+Terminal=true
+Categories=System;Filesystem;
+@@@
+}
+
+
+package() {
+
+cd "$srcdir/$pkgname-$pkgver"
+install -pDm755 $pkgname $pkgdir/usr/bin/$pkgname
+install -pDm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+}