summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNOGISAKA Sadata2019-02-14 23:15:47 +0900
committerNOGISAKA Sadata2019-02-14 23:28:37 +0900
commit6c95659d42bfdcda1217996fabe232150f27a95a (patch)
tree83382e5cbdcaabb9c0ed68e83017fa0b0605a751
parent1fd7d582eaa1129d2cdbaefe5141322fb16d22e8 (diff)
downloadaur-6c95659d42bfdcda1217996fabe232150f27a95a.tar.gz
Bump to 1.1.0-1 and update PKGBUILD
Updates: - Use python2 instead of python on build() - Set python2-setuptools as makedepends
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31107a0e209f..cb288081c0a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Sep 9 00:07:44 UTC 2018
pkgbase = python2-ipwhois
pkgdesc = Retrieve and parse whois data for IPv4 and IPv6 addresses
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/secynic/ipwhois
arch = any
license = MIT
depends = python2
depends = python2-dnspython
- source = https://github.com/secynic/ipwhois/archive/v1.0.0.zip
- sha512sums = 678ca8b3e9cbc41b364536f6b0e84053a0385a9238c22afcb6e860e4097e4c25b72b360997b74392aa6c8e8bb849c01c9f069b9078f8b341361f662cf9250ed2
+ source = https://github.com/secynic/ipwhois/archive/v1.1.0.zip
+ sha512sums = aa5186ec59403ad016260e3bc09bdf2e488553cd68301b0e1c3ef8d72bdbbb8428ed0ac10754315ffc95aea7e4102580acc73da77f8d2ae508ad13e2cd7c54e1
pkgname = python2-ipwhois
diff --git a/PKGBUILD b/PKGBUILD
index 51227bdbaa95..5b5bc52cc0f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,21 @@
pkgname=python2-ipwhois
_pkgname=ipwhois
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="Retrieve and parse whois data for IPv4 and IPv6 addresses"
url="https://github.com/secynic/ipwhois"
arch=(any)
license=('MIT')
depends=('python2' 'python2-dnspython')
+makedepends=('python2-setuptools')
source=("https://github.com/secynic/${_pkgname}/archive/v${pkgver}.zip")
-sha512sums=('678ca8b3e9cbc41b364536f6b0e84053a0385a9238c22afcb6e860e4097e4c25b72b360997b74392aa6c8e8bb849c01c9f069b9078f8b341361f662cf9250ed2')
+sha512sums=('aa5186ec59403ad016260e3bc09bdf2e488553cd68301b0e1c3ef8d72bdbbb8428ed0ac10754315ffc95aea7e4102580acc73da77f8d2ae508ad13e2cd7c54e1')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py build
+ python2 setup.py build
}
package() {
@@ -28,4 +29,3 @@ package() {
}
# vim:set ts=2 sw=2 et:
-