summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilherme Felipe de C. G. da Silva2023-07-12 12:29:56 -0300
committerGuilherme Felipe de C. G. da Silva2023-07-12 12:29:56 -0300
commit6ca5ee75bae327a5efbaa20485ff31bab9e9803a (patch)
tree76217c7fa50669697d5bc2fb4fef79ac4bbe8d93
parent764c68eefd9037268a96298940a05bea11972717 (diff)
downloadaur-6ca5ee75bae327a5efbaa20485ff31bab9e9803a.tar.gz
Add patch for base64.h
-rw-r--r--PKGBUILD9
-rw-r--r--base64.patch12
2 files changed, 20 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35f69b525589..4fffa0189213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guilherme Felipe <guilhermefelipecgs@gmail.com>
pkgname=zytrax-git
-pkgver=1.0.alpha.r9.g16838b3
+pkgver=1.0.alpha.r13.gd60cc42
pkgrel=1
pkgdesc="Easy to use, tracker-inspired music sequencer."
arch=('i686' 'x86_64')
@@ -13,10 +13,12 @@ optdepends=('vst-plugins: Package group for vst plugins')
source=(
"$pkgname::git+https://github.com/reduz/zytrax.git"
"zytrax.desktop"
+ "base64.patch"
)
sha256sums=(
'SKIP'
'5058a5b3c2070e7d59db8cb8f14fd45538718a80e79fc8f4de4d62c1252521e8'
+ 'c785b9ddec09ca785a2410f2c7aa6aba8122ae387c3613de99848598425de2d5'
)
pkgver() {
@@ -24,6 +26,11 @@ pkgver() {
git describe --long --tags | sed 's/-/.r/;s/-/./'
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ git apply "$srcdir/base64.patch"
+}
+
build() {
cd "$srcdir/$pkgname"
scons -j$(nproc)
diff --git a/base64.patch b/base64.patch
new file mode 100644
index 000000000000..988c882f104e
--- /dev/null
+++ b/base64.patch
@@ -0,0 +1,12 @@
+diff --git a/globals/base64.h b/globals/base64.h
+index c6c3227..0bcede6 100644
+--- a/globals/base64.h
++++ b/globals/base64.h
+@@ -3,6 +3,7 @@
+
+ #include "vector.h"
+ #include <string>
++#include <cstdint>
+
+ std::string base64_encode(const Vector<uint8_t> &p_buffer);
+ Vector<uint8_t> base64_decode(std::string const &);