summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeest2017-09-19 18:34:47 -0400
committerbeest2017-09-19 18:34:47 -0400
commit6cd2e0504ebe7ba5db9c83b6e0ff287244f35ea6 (patch)
treeda7aec5fe11cd489ac41d9c26b7559e91d2828ed
parent890f865d3eb0e34ed23d8a7c0908f7fbce9c8e5c (diff)
downloadaur-6cd2e0504ebe7ba5db9c83b6e0ff287244f35ea6.tar.gz
tidy PKGBUILD
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD36
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02917160ef58..d0e5aaf591de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = atari800
pkgdesc = An emulator of the Atari 800/800XL/130XE/5200 with various extensions
pkgver = 3.1.0
- pkgrel = 2
+ pkgrel = 3
url = http://atari800.sourceforge.net/
arch = i686
arch = x86_64
- arch = armv6h
license = GPL2
- depends = libpng
depends = sdl
+ optdepends = libpng: PNG screenshot support
source = http://downloads.sourceforge.net/sourceforge/atari800/atari800-3.1.0.tar.gz
md5sums = 354f8756a7f33cf5b7a56377d1759e41
diff --git a/PKGBUILD b/PKGBUILD
index 140909378257..8db5eb05c649 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,29 @@
-# Original Contributor: Vinzenz Vietzke <vinz@archlinux.us>
-# Modified by: Farhan Yousasf <farhany@gmail.com>
-# Modified by: c0mmando <c0mmand0_88@yahoo.com.ar>
-# Maintainer: beest <gnubeest@gmail.com>
+# Maintainer: beest <gnubeest at zoho dot com>
+# Contributor: c0mmando <c0mmand0_88 at yahoo dot com dot ar>
+# Contributor: Farhan Yousasf <farhany at gmail dot com>
+# Contributor: Vinzenz Vietzke <vinz at archlinux dot us>
pkgname=atari800
pkgver=3.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="An emulator of the Atari 800/800XL/130XE/5200 with various extensions"
-arch=('i686' 'x86_64' 'armv6h')
+arch=('i686' 'x86_64')
url="http://atari800.sourceforge.net/"
license=('GPL2')
-depends=('libpng' 'sdl')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+depends=('sdl')
+optdepends=('libpng: PNG screenshot support')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz")
md5sums=('354f8756a7f33cf5b7a56377d1759e41')
build()
{
- # This emulator has a few linux compatible targets. Edit the target
- # and depends variables if you'd like a different target.
- # Valid choices are: default , android , falcon , javanvm , javanvm-basic , ps2 , windx , x11
- # see -> ./configure --target --help
- #default=autodetect graphics and sound
- _target=default
-
- # Pass the reponse to the configure script
-
- cd ${srcdir}/${pkgname}-${pkgver}/src
- ./configure --target=${_target} --prefix=/usr
- make
+ cd "${pkgname}-${pkgver}"/src
+ ./configure --prefix=/usr
+ make
}
package()
{
- cd ${srcdir}/${pkgname}-${pkgver}/src
- make DESTDIR=${pkgdir} install
+ cd "${pkgname}-${pkgver}"/src
+ make DESTDIR="${pkgdir}/" install
}