summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRealStickman2023-01-13 09:33:23 +0100
committerRealStickman2023-01-13 09:33:23 +0100
commit6cf17122ca5803608d8eeb47e3f62f552d886f4e (patch)
tree43f47b81a1eac23429d188e1de5dc9a1773cf96b
parent98cf6953dc2087062d6a372798da1c48b49ff1ec (diff)
downloadaur-6cf17122ca5803608d8eeb47e3f62f552d886f4e.tar.gz
Update dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc2fdb4faeac..2c1c700e17e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = sublime-music-git
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.
- pkgver = v0.11.16.r22.gfd40be6
+ pkgver = v0.11.16.r49.g430895e
pkgrel = 1
url = https://sublimemusic.app
arch = any
license = GPL3
makedepends = python-pip
- makedepends = python-poetry
+ makedepends = python-flit
makedepends = python-sphinx
makedepends = tar
depends = python
@@ -14,13 +14,13 @@ pkgbase = sublime-music-git
depends = python-dataclasses-json
depends = python-dateutil
depends = python-deepdiff
- depends = python-fuzzywuzzy
depends = python-gobject
depends = python-levenshtein
depends = python-mpv
depends = python-peewee
depends = python-requests
depends = python-semver
+ depends = python-thefuzz
optdepends = libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to
optdepends = libnotify: for system song notification support
optdepends = python-keyring: support for storing passwords in the system keyring
@@ -28,7 +28,7 @@ pkgbase = sublime-music-git
optdepends = python-bottle: support for casting downloaded files to Chromecasts on the same LAN
provides = sublime-music
conflicts = sublime-music
- source = sublime-music-git::git+https://gitlab.com/sublime-music/sublime-music.git
+ source = sublime-music-git::git+https://github.com/sublime-music/sublime-music.git
source = sublime-music.desktop
sha256sums = SKIP
sha256sums = fd84f6b408aa78a21a2990a0b78c4851db80b7ef0f7e7573cc82b57d8abb4d0c
diff --git a/PKGBUILD b/PKGBUILD
index 36048e6a96bf..098dfa808c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase='sublime-music-git'
pkgname=('sublime-music-git')
_module='sublime-music'
-pkgver=v0.11.16.r22.gfd40be6
+pkgver=v0.11.16.r49.g430895e
pkgrel=1
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.'
url='https://sublimemusic.app'
@@ -15,13 +15,13 @@ depends=(
'python-dataclasses-json'
'python-dateutil'
'python-deepdiff'
- 'python-fuzzywuzzy'
'python-gobject'
'python-levenshtein'
'python-mpv'
'python-peewee'
'python-requests'
'python-semver'
+ 'python-thefuzz'
)
optdepends=(
'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
@@ -32,14 +32,14 @@ optdepends=(
)
makedepends=(
'python-pip'
- 'python-poetry'
+ 'python-flit'
'python-sphinx'
'tar'
)
license=('GPL3')
arch=('any')
source=(
- 'sublime-music-git::git+https://gitlab.com/sublime-music/sublime-music.git'
+ 'sublime-music-git::git+https://github.com/sublime-music/sublime-music.git'
'sublime-music.desktop'
)
sha256sums=('SKIP'
@@ -53,7 +53,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
- poetry build
+ flit build
}
package() {