summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:22:54 +0200
committerKevin Brubeck Unhammer2015-07-14 10:22:54 +0200
commit6d0f7e25bb0189a921b63ff56b21bc4e9bed653d (patch)
treeaf27fa6b9d93fa88205839bea037d40e83dbbf54
downloadaur-6d0f7e25bb0189a921b63ff56b21bc4e9bed653d.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile.am.patch81
-rw-r--r--PKGBUILD32
-rw-r--r--configure.ac.patch20
4 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..065f9e793e95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = apertium-es-pt
+ pkgdesc = Apertium language data for the Spanish-Portuguese translator.
+ pkgver = 1.0.3
+ pkgrel = 2
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = autoconf
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-es-pt-1.0.3.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ md5sums = 0549493582ed682c6369b6a3ab3f09b5
+ md5sums = 980ec38601b6da839b0f98fab5821cde
+ md5sums = 29e1b3e85af2d026f3d48d19a4924986
+
+pkgname = apertium-es-pt
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..332c327b1c01
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,81 @@
+--- ../apertium-es-pt-1.0.3/Makefile.am 2007-10-02 10:38:51.000000000 +0200
++++ apertium-es-pt-1.0.3/Makefile.am 2010-09-15 16:34:42.000000000 +0200
+@@ -31,11 +31,11 @@
+ $(PREFIX1b).autobil.bin: es-pt_BR.dix
+ apertium-validate-dictionary es-pt_BR.dix
+ lt-comp lr es-pt_BR.dix $@
+-
++
+ $(PREFIX1b).autogen.bin: pt_BR.dix
+ apertium-validate-dictionary pt_BR.dix
+ lt-comp rl pt_BR.dix $@
+-
++
+ $(PREFIX1).autopgen.bin: $(BASENAME).post-$(LANG2).dix
+ apertium-validate-dictionary $(BASENAME).post-$(LANG2).dix
+ lt-comp lr $(BASENAME).post-$(LANG2).dix $@
+@@ -60,13 +60,13 @@
+ apertium-validate-transfer $(BASENAME).trules-$(PREFIX2).xml
+ apertium-preprocess-transfer $(BASENAME).trules-$(PREFIX2).xml \
+ trules-$(PREFIX2).bin
+-
++
+ trules-$(PREFIX1).xml: $(BASENAME).trules-$(PREFIX1).xml
+ ./filterrules.sh pt_PT $(BASENAME).trules-$(PREFIX1).xml >$@
+
+ trules-$(PREFIX1b).xml: $(BASENAME).trules-$(PREFIX1).xml
+ ./filterrules.sh pt_BR $(BASENAME).trules-$(PREFIX1).xml >$@
+-
++
+ trules-$(PREFIX1).bin: trules-$(PREFIX1).xml
+ apertium-validate-transfer trules-$(PREFIX1).xml
+ apertium-preprocess-transfer trules-$(PREFIX1).xml $@
+@@ -87,20 +87,20 @@
+ $(PREFIX2)-supervised.make $(PREFIX2)-unsupervised.make \
+ $(LANG2).dix $(LANG2b).dix $(PREFIX1).dix $(PREFIX1b).dix \
+ filter.sh filter.xsl filterrules.sh filterrules.xsl modes.xml
+-
++
+ apertium_es_ptdir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_es_modesdir=$(prefix)/share/apertium/modes/
+
+
+ pt.dix: $(BASENAME).$(LANG2).dix
+ ./filter.sh pt left $(BASENAME).$(LANG2).dix >$@
+-
++
+ pt_BR.dix: $(BASENAME).$(LANG2).dix
+ ./filter.sh br left $(BASENAME).$(LANG2).dix >$@
+-
++
+ es-pt.dix: $(BASENAME).$(PREFIX1).dix
+ ./filter.sh pt right $(BASENAME).$(PREFIX1).dix >$@
+-
++
+ es-pt_BR.dix: $(BASENAME).$(PREFIX1).dix
+ ./filter.sh br right $(BASENAME).$(PREFIX1).dix >$@
+
+@@ -115,7 +115,7 @@
+
+ modes: modes.xml
+ apertium-gen-modes modes.xml
+-
++
+ apertium_es_pt_DATA=$(PREFIX1).automorf.bin $(PREFIX2).automorf.bin \
+ $(PREFIX1).autobil.bin $(PREFIX2).autobil.bin \
+ $(PREFIX1b).autobil.bin $(PREFIX1b).autogen.bin \
+@@ -128,10 +128,10 @@
+
+ install-data-local:
+ $(prefix)/bin/apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) $(PREFIX1).mode $(apertium_es_modesdir)
+- $(INSTALL_DATA) $(PREFIX1b).mode $(apertium_es_modesdir)
+- $(INSTALL_DATA) $(PREFIX2).mode $(apertium_es_modesdir)
+- $(INSTALL_DATA) $(BASENAME).trules-$(PREFIX2).xml $(BASENAME).trules-$(PREFIX1).xml trules-$(PREFIX1b).xml $(apertium_es_ptdir)
++ $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_es_modesdir)
++ $(INSTALL_DATA) $(PREFIX1b).mode $(DESTDIR)$(apertium_es_modesdir)
++ $(INSTALL_DATA) $(PREFIX2).mode $(DESTDIR)$(apertium_es_modesdir)
++ $(INSTALL_DATA) $(BASENAME).trules-$(PREFIX2).xml $(BASENAME).trules-$(PREFIX1).xml trules-$(PREFIX1b).xml $(DESTDIR)$(apertium_es_ptdir)
+
+
+ CLEANFILES = -rf $(TARGETS) pt.dix pt_BR.dix es-pt.dix es-pt_BR.dix modes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e367fdcc0947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-es-pt
+pkgver=1.0.3
+pkgrel=2
+pkgdesc="Apertium language data for the Spanish-Portuguese translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig' 'autoconf')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch")
+md5sums=('0549493582ed682c6369b6a3ab3f09b5'
+ '980ec38601b6da839b0f98fab5821cde'
+ '29e1b3e85af2d026f3d48d19a4924986')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+}
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..6ee8c4be865a
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,20 @@
+--- ../apertium-es-pt-1.0.3/configure.ac 2007-10-02 12:39:06.000000000 +0200
++++ apertium-es-pt-1.0.3/configure.ac 2010-09-21 16:08:38.124072111 +0200
+@@ -10,9 +10,14 @@
+ AC_PROG_AWK
+ AC_CONFIG_HEADER([config])
+
+-PKG_CHECK_MODULES(APERTIUM, apertium-3.0 >= 3.0.0)
+-
+-APERTIUM_VER=30
++PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++[
++ APERTIUM_VER=31
++],
++[
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++])
+
+ AC_SUBST(APERTIUM_VER)
+