summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj-james2022-02-08 10:42:49 -0800
committerj-james2022-02-08 10:42:49 -0800
commit6d33a41b37fbf09e08a6fd1c12a3b197e372996f (patch)
tree878081950a2979cd3549ab31ae0ab6455d5b090e
parent5e1b38e6f2a2f77db4aab15013953cbfa77a4269 (diff)
downloadaur-6d33a41b37fbf09e08a6fd1c12a3b197e372996f.tar.gz
update to pakku 0.15
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e637ce8a810..bd17a257dcae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pakku
- pkgdesc = Pacman wrapper with AUR support
- pkgver = 0.14
+ pkgdesc = Pacman wrapper and AUR helper with a pacman-like user interface
+ pkgver = 0.15
pkgrel = 1
- url = https://github.com/kitsunyan/pakku
+ url = https://github.com/zqqw/pakku
arch = i686
arch = x86_64
arch = armv6h
@@ -10,11 +10,12 @@ pkgbase = pakku
arch = aarch64
license = GPL3
makedepends = nim
+ makedepends = git
+ makedepends = asciidoc
depends = libcurl.so
depends = git
backup = etc/pakku.conf
- source = https://github.com/kitsunyan/pakku/releases/download/v0.14/pakku-0.14.tar.xz
- sha256sums = 2e5e1db1651f3630a3a9f62d8341384c2d24c3573f2a2d0803d8e795990785c7
+ source = https://github.com/zqqw/pakku/archive/refs/tags/v0.15.tar.gz
+ sha256sums = 770f4344543d6072ff2b18a2c212a5c3e56e16f6c86ca4b9097eaadf54a26c73
pkgname = pakku
-
diff --git a/PKGBUILD b/PKGBUILD
index 4e63dc0474e9..33a918259ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: kitsunyan <`echo a2l0c3VueWFuQGFpcm1haWwuY2MK | base64 -d`>
+# Contributor: kitsunyan <`echo a2l0c3VueWFuQGFpcm1haWwuY2MK | base64 -d`>
+# Maintainer: j-james <jj@j-james.me>
pkgname=pakku
-pkgver=0.14
+pkgver=0.15
pkgrel=1
-pkgdesc='Pacman wrapper with AUR support'
+pkgdesc='Pacman wrapper and AUR helper with a pacman-like user interface'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/kitsunyan/$pkgname"
+url="https://github.com/zqqw/$pkgname"
license=('GPL3')
depends=('libcurl.so' 'git')
-makedepends=('nim')
+makedepends=('nim' 'git' 'asciidoc')
backup=('etc/pakku.conf')
-source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('2e5e1db1651f3630a3a9f62d8341384c2d24c3573f2a2d0803d8e795990785c7')
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('770f4344543d6072ff2b18a2c212a5c3e56e16f6c86ca4b9097eaadf54a26c73')
build() {
local addargs=()