summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary DeLaney2015-08-10 15:46:52 -0500
committerGary DeLaney2015-08-10 15:46:52 -0500
commit6d548312ecb297a3f5e7b29dea8318dac9e7e4b9 (patch)
treefbeef11dcbe436081b6bdbed98ba392be0f2582a
downloadaur-6d548312ecb297a3f5e7b29dea8318dac9e7e4b9.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8425c36cbbc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bake-sl-git
+ pkgdesc = An easy to use build system. Designed to be make/autotools for the 21st century. (Semplice Linux Fork)
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/semplice/bake
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = itstool
+ makedepends = vala
+ provides = bake-sl-git
+ conflicts = bake-sl-git
+ conflicts = bake
+ source = bake::git://github.com/semplice/bake.git#branch=semplice
+ md5sums = SKIP
+
+pkgname = bake-sl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc67b0b4d0bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..156424e7b974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gary DeLaney <gld1982ltd@gmail.com>
+
+_gitroot="git://github.com/semplice/bake.git"
+_gitbranch=semplice
+_gitname=bake
+
+pkgname="$_gitname-sl-git"
+pkgver=0
+pkgrel=1
+pkgdesc="An easy to use build system. Designed to be make/autotools for the 21st century. (Semplice Linux Fork)"
+arch=('i686' 'x86_64')
+url="https://github.com/semplice/bake"
+license=('LGPL')
+groups=()
+depends=()
+makedepends=('itstool' 'vala')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}" "bake")
+replaces=()
+backup=()
+options=()
+install=
+source=("${_gitname}::${_gitroot}#branch=${_gitbranch}")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-sl-git}"
+ printf "%s" "$(git describe --abbrev=0 | sed 's/[A-Za-z]*//g;s/[!@#\$%^&*()/]//g;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-sl-git}"
+ make
+ ./bake-bootstrap --configure install-directory="$pkgdir/"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-sl-git}"
+ ./bake-bootstrap install
+}