summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Seo2022-08-15 11:16:43 +0900
committerStephen Seo2022-08-15 11:17:18 +0900
commit6d5e2767a8c6471a8671694741a62548e387c0b1 (patch)
tree59cbf657162aa0258184fc7040d6328e16b2b033
parent77d6e5440c1e305fbf7abf2673ecb66e8e5d85f2 (diff)
downloadaur-6d5e2767a8c6471a8671694741a62548e387c0b1.tar.gz
Update to raylib 4.2.0
Use internal bundled GLFW instead of mingw-w64-glfw to fix builds. This is done because Raylib bundles GLFW in its repo, and currently it uses a version of GLFW that has changes that, as of 2022-08-15, does not exist in the latest release of GLFW, which is being used by Raylib 4.2.0.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--raylib_glfw.patch2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1de991befe55..1c1e0a4299c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-raylib
pkgdesc = Simple and easy to use game programming library (mingw-w64)
- pkgver = 4.0.0
+ pkgver = 4.2.0
pkgrel = 1
url = https://www.raylib.com
arch = any
@@ -8,13 +8,12 @@ pkgbase = mingw-w64-raylib
makedepends = ninja
makedepends = mingw-w64-cmake
depends = mingw-w64-crt
- depends = mingw-w64-glfw
options = !strip
options = !buildflags
options = staticlibs
- source = raylib_4.0.0.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/4.0.0.tar.gz
+ source = raylib_4.2.0.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/4.2.0.tar.gz
source = raylib_glfw.patch
- md5sums = 7b4ffb9d3b6a01806be21a7cd93e2c53
- md5sums = ee6b877e9fca8e5e6df2f287204ab996
+ md5sums = 5f44f310d13f64f04d03ce6f4127cac7
+ md5sums = a44c1130eac923910f3047696c9a7363
pkgname = mingw-w64-raylib
diff --git a/PKGBUILD b/PKGBUILD
index 3235261b73c2..37540aef7296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Stephen Seo <seo.disparate@gmail.com>
pkgname=mingw-w64-raylib
-pkgver=4.0.0
+pkgver=4.2.0
pkgrel=1
pkgdesc="Simple and easy to use game programming library (mingw-w64)"
arch=(any)
url="https://www.raylib.com"
license=(ZLIB)
groups=()
-depends=(mingw-w64-crt mingw-w64-glfw)
+# Use internal GLFW for now, since the bundled GLFW is newer
+#depends=(mingw-w64-crt mingw-w64-glfw)
+depends=(mingw-w64-crt)
makedepends=(ninja mingw-w64-cmake)
replaces=()
backup=()
@@ -19,11 +21,10 @@ source=(
)
noextract=()
md5sums=(
- '7b4ffb9d3b6a01806be21a7cd93e2c53'
- 'ee6b877e9fca8e5e6df2f287204ab996'
+ 5f44f310d13f64f04d03ce6f4127cac7
+ a44c1130eac923910f3047696c9a7363
)
-
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
@@ -39,7 +40,7 @@ build() {
-Wno-dev \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_C_FLAGS="$CFLAGS -fPIC -w" \
- -D USE_EXTERNAL_GLFW=ON \
+ -D USE_EXTERNAL_GLFW=OFF \
-D BUILD_EXAMPLES=OFF \
-D BUILD_GAMES=OFF \
-D SHARED=ON \
diff --git a/raylib_glfw.patch b/raylib_glfw.patch
index 7a80ed5c01d3..8f3e28b7ae1b 100644
--- a/raylib_glfw.patch
+++ b/raylib_glfw.patch
@@ -1,7 +1,7 @@
Fixes issues with name conflicts building with external glfw
--- a/src/rcore.c
+++ b/src/rcore.c
-@@ -196,7 +196,7 @@
+@@ -214,7 +214,7 @@
// Support retrieving native window handlers
#if defined(_WIN32)