summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLance2015-08-13 04:25:20 -0700
committerLance2015-08-13 04:25:20 -0700
commit6db19be6ee38cf4dd3b71742eb85dc95fea1e917 (patch)
tree6146c4e06378ed032a160759709a3012d70ace4c
downloadaur-6db19be6ee38cf4dd3b71742eb85dc95fea1e917.tar.gz
Initial upload for AUR4
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD32
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a5138282270
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chunksync
+ pkgdesc = An incremental backup program, especially suited for encrypted disks.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://chunksync.florz.de/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ depends = openssl
+ optdepends = chunkfs
+ provides = chunksync
+ conflicts = chunksync
+ source = http://chunksync.florz.de/chunksync_0.3.tar.gz
+ source = LICENSE
+ sha256sums = e0c27f925c5cf811798466312a56772864b633728c433fb2fcce23c8712b52fc
+ sha256sums = 30b7bcf5380a107e9508394efd22ef46281abfd7ef1abc5ad39d1d1583423e77
+
+pkgname = chunksync
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d77749e67e66
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+Copyright (C) 2009 Florian Zumbiehl <florz@florz.de>
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2 of the License, or (at
+your option) any later version.
+
+This program is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program; if not, write to the Free Software
+Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+02110-1301 USA.
+
+In addition, as a special exception, the author of this program gives
+permission to link the code of its release with the OpenSSL project's
+"OpenSSL" library (or with modified versions of it that use the same
+license as the "OpenSSL" library), and distribute the linked
+executables. You must obey the GNU General Public License in all
+respects for all of the code used other than "OpenSSL". If you modify
+this file, you may extend this exception to your version of the file,
+but you are not obligated to do so. If you do not wish to do so,
+delete this exception statement from your version.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe0a083de6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Raansu <Gero3977@gmail.com>
+# Contributor: Moritz Heidkamp <moritz@twoticketsplease.de>
+pkgname=chunksync
+pkgver=0.3
+pkgrel=1
+pkgdesc="An incremental backup program, especially suited for encrypted disks."
+arch=(i686 x86_64)
+url="http://chunksync.florz.de/"
+license=(custom)
+depends=(openssl)
+makedepends=(perl)
+optdepends=(chunkfs)
+provides=(chunksync)
+conflicts=(chunksync)
+source=(http://chunksync.florz.de/chunksync_${pkgver}.tar.gz LICENSE)
+sha256sums=('e0c27f925c5cf811798466312a56772864b633728c433fb2fcce23c8712b52fc'
+ '30b7bcf5380a107e9508394efd22ef46281abfd7ef1abc5ad39d1d1583423e77')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+