summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-04-06 18:36:26 +0200
committerSebastian 'Swift Geek' Grzywna2017-04-06 18:36:46 +0200
commit6e1afe5f7969b1b10168f8f83885210885af9bc3 (patch)
tree43c1e1a1ae95fc6a786a77e85e06f6d52d2f749d
downloadaur-6e1afe5f7969b1b10168f8f83885210885af9bc3.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02822ff6a419
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Apr 6 16:36:41 UTC 2017
+pkgbase = authprogs-git
+ pkgdesc = SSH Command Authenticator
+ pkgver = a
+ pkgrel = 1
+ url = https://github.com/daethnir/authprogs/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = GPL
+ makedepends = git
+ makedepends = ruby-ronn
+ depends = python2
+ source = git://github.com/daethnir/authprogs.git
+ md5sums = SKIP
+
+pkgname = authprogs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4022b10cac71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Swift Geek
+pkgname=authprogs-git
+_pkgname=authprogs
+pkgver=a
+pkgrel=1
+pkgdesc="SSH Command Authenticator"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/daethnir/authprogs/"
+license=('GPL')
+depends=('python2')
+makedepends=('git' 'ruby-ronn')
+source=("git://github.com/daethnir/authprogs.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD # Fix to better comply with github display
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}