summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGlen D'souza2016-04-15 14:51:15 +0530
committerGlen D'souza2016-04-15 14:51:15 +0530
commit6e2d190264c94c8162ba50cd4746775dcde2d4af (patch)
tree9a6032b16664756023094cbb29475c7c1c3eaca2
parentb8b26b1d66b3c900f65ae703df4db754ee8c0f4b (diff)
downloadaur-6e2d190264c94c8162ba50cd4746775dcde2d4af.tar.gz
Fix building with ffmpeg3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--openscenegraph-ffmpeg3.patch157
3 files changed, 182 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0078fd919e2..af0ed3885748 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 19:38:21 UTC 2015
+# Fri Apr 15 09:18:47 UTC 2016
pkgbase = openscenegraph-git
pkgdesc = An open source, high performance real-time graphics toolkit - git mirror
- pkgver = 20151212
+ pkgver = 20160415
pkgrel = 1
url = http://www.openscenegraph.org/
arch = i686
@@ -11,7 +11,7 @@ pkgbase = openscenegraph-git
makedepends = cmake
makedepends = libvncserver
makedepends = qt5-base
- makedepends = ffmpeg-compat
+ makedepends = ffmpeg
makedepends = mesa
depends = giflib
depends = jasper
@@ -24,13 +24,17 @@ pkgbase = openscenegraph-git
optdepends = openexr
optdepends = poppler-glib
optdepends = qt5-base
- optdepends = ffmpeg-compat
+ optdepends = ffmpeg
provides = openscenegraph-git
provides = openscenegraph
+ provides = openthreads
conflicts = openscenegraph
conflicts = openscenegraph-svn
- source = git://github.com/openscenegraph/osg.git
+ conflicts = openthreads
+ source = git://github.com/openscenegraph/OpenSceneGraph.git
+ source = openscenegraph-ffmpeg3.patch
md5sums = SKIP
+ md5sums = f8151db111ad492ea3bf93971f9a32a9
pkgname = openscenegraph-git
diff --git a/PKGBUILD b/PKGBUILD
index c22ec3cdbcc9..50f209a48577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
-# Maintainer: Glen Dsouza <glen@teameos.org>
+# Maintainer: Glen Dsouza <gdsouza@linuxmail.org>
# Contributor: jmf <jmf at mesecons dot net>
pkgname=openscenegraph-git
-pkgver=20151212
+pkgver=20160415
pkgrel=1
-_gitname=osg
+_gitname=OpenSceneGraph
pkgdesc="An open source, high performance real-time graphics toolkit - git mirror"
arch=('i686' 'x86_64')
url="http://www.openscenegraph.org/"
license=('GPL')
depends=('giflib' 'jasper' 'librsvg' 'xine-lib' 'curl' 'pth')
-makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg-compat' 'mesa')
-optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg-compat')
-provides=('openscenegraph-git' 'openscenegraph')
-conflicts=('openscenegraph' 'openscenegraph-svn')
-source=(git://github.com/openscenegraph/osg.git)
-md5sums=('SKIP')
+makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg' 'mesa')
+optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg')
+provides=('openscenegraph-git' 'openscenegraph' 'openthreads')
+conflicts=('openscenegraph' 'openscenegraph-svn' 'openthreads')
+source=(git://github.com/openscenegraph/OpenSceneGraph.git openscenegraph-ffmpeg3.patch)
+md5sums=('SKIP'
+ 'f8151db111ad492ea3bf93971f9a32a9')
pkgver() {
echo "$(date +"%Y%m%d")"
}
+prepare() {
+ cd OpenSceneGraph
+# Fix build with ffmpeg 3.0 (Debian)
+ patch -p2 -i ../openscenegraph-ffmpeg3.patch
+}
+
build() {
mkdir ${srcdir}/${_gitname}-build/
cd "${srcdir}/${_gitname}-build/"
diff --git a/openscenegraph-ffmpeg3.patch b/openscenegraph-ffmpeg3.patch
new file mode 100644
index 000000000000..586b6010e165
--- /dev/null
+++ b/openscenegraph-ffmpeg3.patch
@@ -0,0 +1,157 @@
+Description: Replace deprecated FFmpeg API
+Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
+Last-Update: <2015-11-02>
+
+--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
++++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
+@@ -71,7 +71,7 @@ void FFmpegDecoderVideo::open(AVStream *
+ findAspectRatio();
+
+ // Find out whether we support Alpha channel
+- m_alpha_channel = (m_context->pix_fmt == PIX_FMT_YUVA420P);
++ m_alpha_channel = (m_context->pix_fmt == AV_PIX_FMT_YUVA420P);
+
+ // Find out the framerate
+ m_frame_rate = av_q2d(stream->avg_frame_rate);
+@@ -91,20 +91,19 @@ void FFmpegDecoderVideo::open(AVStream *
+ throw std::runtime_error("avcodec_open() failed");
+
+ // Allocate video frame
+- m_frame.reset(avcodec_alloc_frame());
++ m_frame.reset(av_frame_alloc());
+
+ // Allocate converted RGB frame
+- m_frame_rgba.reset(avcodec_alloc_frame());
+- m_buffer_rgba[0].resize(avpicture_get_size(PIX_FMT_RGB24, width(), height()));
++ m_frame_rgba.reset(av_frame_alloc());
++ m_buffer_rgba[0].resize(avpicture_get_size(AV_PIX_FMT_RGB24, width(), height()));
+ m_buffer_rgba[1].resize(m_buffer_rgba[0].size());
+
+ // Assign appropriate parts of the buffer to image planes in m_frame_rgba
+- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], PIX_FMT_RGB24, width(), height());
++ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], AV_PIX_FMT_RGB24, width(), height());
+
+ // Override get_buffer()/release_buffer() from codec context in order to retrieve the PTS of each frame.
+ m_context->opaque = this;
+- m_context->get_buffer = getBuffer;
+- m_context->release_buffer = releaseBuffer;
++ m_context->get_buffer2 = getBuffer;
+ }
+
+
+@@ -263,8 +262,8 @@ int FFmpegDecoderVideo::convert(AVPictur
+ #ifdef USE_SWSCALE
+ if (m_swscale_ctx==0)
+ {
+- m_swscale_ctx = sws_getContext(src_width, src_height, (PixelFormat) src_pix_fmt,
+- src_width, src_height, (PixelFormat) dst_pix_fmt,
++ m_swscale_ctx = sws_getContext(src_width, src_height, (AVPixelFormat) src_pix_fmt,
++ src_width, src_height, (AVPixelFormat) dst_pix_fmt,
+ /*SWS_BILINEAR*/ SWS_BICUBIC, NULL, NULL, NULL);
+ }
+
+@@ -311,14 +310,14 @@ void FFmpegDecoderVideo::publishFrame(co
+ AVPicture * const dst = (AVPicture *) m_frame_rgba.get();
+
+ // Assign appropriate parts of the buffer to image planes in m_frame_rgba
+- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], PIX_FMT_RGB24, width(), height());
++ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], AV_PIX_FMT_RGB24, width(), height());
+
+ // Convert YUVA420p (i.e. YUV420p plus alpha channel) using our own routine
+
+- if (m_context->pix_fmt == PIX_FMT_YUVA420P)
++ if (m_context->pix_fmt == AV_PIX_FMT_YUVA420P)
+ yuva420pToRgba(dst, src, width(), height());
+ else
+- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
++ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
+
+ // Wait 'delay' seconds before publishing the picture.
+ int i_delay = static_cast<int>(delay * 1000000 + 0.5);
+@@ -345,7 +344,7 @@ void FFmpegDecoderVideo::publishFrame(co
+
+ void FFmpegDecoderVideo::yuva420pToRgba(AVPicture * const dst, AVPicture * const src, int width, int height)
+ {
+- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
++ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
+
+ const size_t bpp = 4;
+
+@@ -363,31 +362,28 @@ void FFmpegDecoderVideo::yuva420pToRgba(
+ }
+ }
+
+-
+-
+-int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture)
++int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture, int flags)
+ {
++ AVBufferRef *ref;
+ const FFmpegDecoderVideo * const this_ = reinterpret_cast<const FFmpegDecoderVideo*>(context->opaque);
+
+- const int result = avcodec_default_get_buffer(context, picture);
++ const int result = avcodec_default_get_buffer2(context, picture, flags);
+ int64_t * p_pts = reinterpret_cast<int64_t*>( av_malloc(sizeof(int64_t)) );
+
+ *p_pts = this_->m_packet_pts;
+ picture->opaque = p_pts;
+
++ ref = av_buffer_create((uint8_t *)picture->opaque, sizeof(int64_t), FFmpegDecoderVideo::freeBuffer, picture->buf[0], flags);
++ picture->buf[0] = ref;
++
+ return result;
+ }
+
+-
+-
+-void FFmpegDecoderVideo::releaseBuffer(AVCodecContext * const context, AVFrame * const picture)
++void FFmpegDecoderVideo::freeBuffer(void *opaque, uint8_t *data)
+ {
+- if (picture != 0)
+- av_freep(&picture->opaque);
+-
+- avcodec_default_release_buffer(context, picture);
++ AVBufferRef *ref = (AVBufferRef *)opaque;
++ av_buffer_unref(&ref);
++ av_free(data);
+ }
+
+-
+-
+ } // namespace osgFFmpeg
+--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
++++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
+@@ -94,8 +94,8 @@ private:
+ int src_pix_fmt, int src_width, int src_height);
+
+
+- static int getBuffer(AVCodecContext * context, AVFrame * picture);
+- static void releaseBuffer(AVCodecContext * context, AVFrame * picture);
++ static int getBuffer(AVCodecContext * context, AVFrame * picture, int flags);
++ static void freeBuffer(void * opaque, uint8_t *data);
+
+ PacketQueue & m_packets;
+ FFmpegClocks & m_clocks;
+--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
++++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
+@@ -19,7 +19,7 @@ extern "C"
+ #include <libavutil/pixdesc.h>
+ }
+
+-inline PixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
++inline AVPixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
+
+
+ namespace osgFFmpeg {
+--- src/OpenSceneGraph-3.4.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp.orig 2016-02-18 21:25:39.627923629 +0000
++++ src/OpenSceneGraph-3.4.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp 2016-02-18 21:26:17.071140100 +0000
+@@ -227,8 +227,7 @@
+ if (avcodec_open2(m_context, p_codec, NULL) < 0)
+ throw std::runtime_error("avcodec_open() failed");
+
+- m_context->get_buffer = avcodec_default_get_buffer;
+- m_context->release_buffer = avcodec_default_release_buffer;
++ m_context->get_buffer2 = avcodec_default_get_buffer2;
+
+ }
+