summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2022-08-19 23:36:29 +0200
committerDaniel Maslowski2022-08-19 23:36:29 +0200
commit6e313a897f59c0d6057ff13753c355cd342895f1 (patch)
tree1d1b7d92ac4e9c31c2c319e37965d5c8ecc8266b
parent6a3c2d4c15a635558ded0dc563204a27fd878b08 (diff)
downloadaur-6e313a897f59c0d6057ff13753c355cd342895f1.tar.gz
rework
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d4d4e3333cf..39f48727214c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,17 +6,15 @@ pkgbase = graphqlmap-git
arch = any
license = MIT
makedepends = git
+ makedepends = python-setuptools
depends = python
- depends = python-setuptools
depends = python-argparse
depends = python-requests
+ depends = python-rl
provides = graphqlmap
conflicts = graphqlmap
options = !emptydirs
- source = git://github.com/swisskyrepo/graphqlmap.git
- source = setup.py
- sha512sums = SKIP
- sha512sums = f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346
+ source = https://github.com/swisskyrepo/graphqlmap.git
+ sha512sums = 28a6def2655bc71b0914231d779d2efa140a6fd9c5b1c2de1361cd4669cff251bd6052ac1d3bf988f9f554f44c8e71176b3099327e922cee5794ac82de3cb317
pkgname = graphqlmap-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 295bcaebfd71..1ea52662493d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,21 @@ url="https://github.com/swisskyrepo/GraphQLmap"
license=('MIT')
depends=(
'python'
- 'python-setuptools'
'python-argparse'
'python-requests'
+ 'python-rl'
)
makedepends=(
'git'
+ 'python-setuptools'
)
provides=("$_pyname")
conflicts=(graphqlmap)
options=(!emptydirs)
source=(
- git://github.com/swisskyrepo/$_pyname.git
- setup.py
+ https://github.com/swisskyrepo/$_pyname.git
)
-sha512sums=('SKIP'
- 'f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346')
+sha512sums=('28a6def2655bc71b0914231d779d2efa140a6fd9c5b1c2de1361cd4669cff251bd6052ac1d3bf988f9f554f44c8e71176b3099327e922cee5794ac82de3cb317')
pkgver() {
cd "$_pyname"
@@ -34,14 +33,6 @@ pkgver() {
package() {
cd "$_pyname"
- sed -i "s#from attacks#from graphqlmap.attacks#" graphqlmap.py
- sed -i "s#from utils#from graphqlmap.utils#" attacks.py
- mkdir bin
- mv graphqlmap.py bin/graphqlmap
- mkdir graphqlmap
- mv *.py graphqlmap/
- touch graphqlmap/__init__.py
- mv ../setup.py .
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm 644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
}