summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:47:43 +0200
committerDaniel Nagy2015-06-08 19:47:43 +0200
commit6e6884ab7795ee5dcfeadac3f120f19a27f13fcc (patch)
tree7d53493b1f60ebbfcd4808f4c6dbd7b8094f49a8
downloadaur-6e6884ab7795ee5dcfeadac3f120f19a27f13fcc.tar.gz
import to aur4
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-bio.install18
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82efb1afe0e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = haskell-bio
+ pkgdesc = A bioinformatics library
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/bio
+ install = haskell-bio.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = ghc
+ depends = haskell-quickcheck>=2.0
+ depends = haskell-array
+ depends = haskell-binary>=0.4
+ depends = haskell-bytestring>=0.9.1
+ depends = haskell-containers
+ depends = haskell-directory
+ depends = haskell-mtl
+ depends = haskell-old-time
+ depends = haskell-parallel
+ depends = haskell-parsec
+ depends = haskell-process
+ depends = haskell-random
+ depends = haskell-tagsoup>=0.8
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/bio/0.5.3/bio-0.5.3.tar.gz
+ md5sums = b5002c48bcee7741264ed6e46ac7a5ca
+
+pkgname = haskell-bio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b55ed8b50c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=bio
+pkgname=haskell-bio
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="A bioinformatics library"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('LGPL')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-quickcheck>=2.0' 'haskell-array' 'haskell-binary>=0.4' 'haskell-bytestring>=0.9.1' 'haskell-containers' 'haskell-directory' 'haskell-mtl' 'haskell-old-time' 'haskell-parallel' 'haskell-parsec' 'haskell-process' 'haskell-random' 'haskell-tagsoup>=0.8')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ sed -i -e "s, && <0.5,,g" bio.cabal
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+}
+md5sums=('b5002c48bcee7741264ed6e46ac7a5ca')
diff --git a/haskell-bio.install b/haskell-bio.install
new file mode 100644
index 000000000000..35e6c5e68c2a
--- /dev/null
+++ b/haskell-bio.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-bio
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}