summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Strobl2017-10-27 21:01:29 +0200
committerDaniel Strobl2017-10-27 21:01:29 +0200
commit6ea5d739f8b5a6bc7e58a12254a1570a3437dbb0 (patch)
tree414fd316fe9a88031a2a669e65e4fbc5820aec84
downloadaur-6ea5d739f8b5a6bc7e58a12254a1570a3437dbb0.tar.gz
first version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0547e23ae1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = welle.io-git
+ pkgdesc = Open source DAB and DAB+ software defined radio
+ pkgver = V20170826.r134.gfea3a21
+ pkgrel = 1
+ url = https://github.com/AlbrechtL/welle.io
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ depends = qt5-multimedia
+ depends = qt5-declarative
+ depends = qt5-charts
+ depends = fftw
+ depends = faad2
+ depends = rtl-sdr
+ depends = airspy
+ provides = welle.io
+ conflicts = welle.io
+ source = git://github.com/AlbrechtL/welle.io
+ md5sums = SKIP
+
+pkgname = welle.io-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5703df84b83f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Strobl <danielstrobl:gmail>
+pkgname=welle.io-git
+pkgver=V20170826.r134.gfea3a21
+pkgrel=1
+pkgdesc="Open source DAB and DAB+ software defined radio"
+arch=('x86_64')
+url="https://github.com/AlbrechtL/welle.io"
+license=('GPL')
+depends=('qt5-multimedia' 'qt5-declarative' 'qt5-charts' 'fftw' 'faad2' 'rtl-sdr' 'airspy')
+makedepends=('git' 'gcc')
+provides=('welle.io')
+conflicts=('welle.io')
+source=('git://github.com/AlbrechtL/welle.io')
+md5sums=('SKIP')
+
+pkgver() {
+ cd welle.io
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd welle.io
+ qmake welle.io.pro
+ make
+}
+
+package() {
+ cd welle.io
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ mkdir $pkgdir/usr/share
+ mkdir $pkgdir/usr/share/applications
+ mkdir $pkgdir/usr/share/pixmaps
+ cp welle-io $pkgdir/usr/bin
+ cp welle-io.desktop $pkgdir/usr/share/applications
+ cp icon.png $pkgdir/usr/share/pixmaps/welle-io.png
+}