summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorz3ntu2016-04-10 00:44:05 +0200
committerz3ntu2016-04-10 00:44:05 +0200
commit6ec14edf0c2e473d54d9a351b04c14cd65c2a036 (patch)
treee4a80276c90a30da72b804a68a78e64453fbbae3
downloadaur-6ec14edf0c2e473d54d9a351b04c14cd65c2a036.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..384050b58b85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 9 22:43:48 UTC 2016
+pkgbase = azure-vhd-utils-for-go-git
+ pkgdesc = Azure VHD utilities for Go.
+ pkgver = r21.7db4795
+ pkgrel = 1
+ url = https://github.com/Microsoft/azure-vhd-utils-for-go
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = azure-vhd-utils-for-go-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd40545b3a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+
+pkgname=azure-vhd-utils-for-go-git
+pkgver=r21.7db4795
+pkgrel=1
+pkgdesc="Azure VHD utilities for Go."
+arch=('x86_64' 'i686')
+url="https://github.com/Microsoft/azure-vhd-utils-for-go"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+_gourl=github.com/Microsoft/azure-vhd-utils-for-go
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ export GOPATH="$srcdir/build"
+ go get -fix -v -x ${_gourl}
+}
+
+package() {
+ install -Dm755 $srcdir/build/bin/azure-vhd-utils-for-go "$pkgdir/usr/bin/vhd"
+ install -Dm644 $srcdir/build/src/${_gourl}/LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: