summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcd19922020-01-28 18:42:40 -0600
committermcd19922020-01-28 18:42:40 -0600
commit6ed80b2724aae2261757be276f6f6bf0b91fd184 (patch)
treefca32272a6b077219bfd2f835a45ac474bb9c6b9
parentddf1ab3f2ba64aa2f66f9b9eb6a806dd93d977a5 (diff)
downloadaur-6ed80b2724aae2261757be276f6f6bf0b91fd184.tar.gz
Switch to dev branch and use python-unicorn-git
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e4e88647e9f..39fe60bf9e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pwntools-git
- pkgdesc = A CTF framework and exploit development library. (git branch dev3)
- pkgver = 3.13.0beta0.r226.gfb117841
+ pkgdesc = A CTF framework and exploit development library. (git branch dev)
+ pkgver = 4.1.0beta0.r10.g42abafdd
pkgrel = 1
url = https://github.com/Gallopsled/pwntools
arch = any
@@ -11,7 +11,7 @@ pkgbase = python-pwntools-git
depends = python-pyelftools
depends = python-tox
depends = python-mako
- depends = python-unicorn
+ depends = python-unicorn-git
depends = python-psutil
depends = python-dateutil
depends = python-pysocks
@@ -26,7 +26,7 @@ pkgbase = python-pwntools-git
depends = python-packaging
optdepends = gdb: binary debugging
provides = python-pwntools
- source = python-pwntools-git::git+https://github.com/Gallopsled/pwntools.git#branch=dev3
+ source = python-pwntools-git::git+https://github.com/Gallopsled/pwntools.git#branch=dev
sha256sums = SKIP
pkgname = python-pwntools-git
diff --git a/PKGBUILD b/PKGBUILD
index a1762118e363..485b0cf27e78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
pkgname=python-pwntools-git
-pkgver=3.13.0beta0.r226.gfb117841
+pkgver=4.1.0beta0.r10.g42abafdd
pkgrel=1
-pkgdesc='A CTF framework and exploit development library. (git branch dev3)'
+pkgdesc='A CTF framework and exploit development library. (git branch dev)'
url='https://github.com/Gallopsled/pwntools'
arch=('any')
license=('GPL')
makedepends=('make')
depends=('python' 'python-intervaltree' 'python-pyelftools' 'python-tox' 'python-mako'
- 'python-unicorn' 'python-psutil' 'python-dateutil' 'python-pysocks' 'python-pygments'
+ 'python-unicorn-git' 'python-psutil' 'python-dateutil' 'python-pysocks' 'python-pygments'
'python-pip' 'python-pyserial' 'python-paramiko' 'ropgadget' 'python-capstone'
'python-requests' 'python-psutil' 'python-packaging')
optdepends=('gdb: binary debugging')
-source=("${pkgname}::git+https://github.com/Gallopsled/pwntools.git#branch=dev3")
+source=("${pkgname}::git+https://github.com/Gallopsled/pwntools.git#branch=dev")
sha256sums=('SKIP')
provides=('python-pwntools')
@@ -25,8 +25,6 @@ pkgver() {
prepare() {
cd ${pkgname}
- #sed -i "s/'sortedcontainers<2.0'/'sortedcontainers'/" setup.py
- #sed -i "s/'intervaltree<3.0'/'intervaltree'/" setup.py
}
build() {