summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Sauter2023-01-25 15:32:23 +0100
committerMoritz Sauter2023-01-25 15:33:09 +0100
commit6edb16d6c811c17827d9860dfd96c64c4ebb01a3 (patch)
tree3245da738d149d9d88c5cb0f92518b270dffa3b7
downloadaur-6edb16d6c811c17827d9860dfd96c64c4ebb01a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD53
-rw-r--r--i3status-rust.install9
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6130522b17c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = i3status-rust-full-git
+ pkgdesc = Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust
+ pkgver = 0.30.0.r2998.g05b44ce1
+ pkgrel = 1
+ url = https://github.com/greshake/i3status-rust
+ install = i3status-rust.install
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ depends = libpulse
+ depends = lm_sensors
+ depends = notmuch
+ optdepends = alsa-utils: for the volume block
+ optdepends = bluez: for the bluetooth block
+ optdepends = fakeroot: for the pacman block to show pending updates
+ optdepends = kdeconnect: for the kdeconnect block
+ optdepends = powerline-fonts: for all themes using the powerline arrow char
+ optdepends = pulseaudio: for the volume block
+ optdepends = speedtest-cli: for the speedtest block
+ optdepends = ttf-font-awesome: for the awesome icons
+ optdepends = upower: for the battery block
+ provides = i3status-rust
+ conflicts = i3status-rust
+ source = i3status-rust-full::git+https://github.com/greshake/i3status-rust
+ sha1sums = SKIP
+
+pkgname = i3status-rust-full-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d64130fdd229
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*zst
+i3status-rust-full/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..389c401acb97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Moritz Sauter <moritz.sauter7+aur at gmail dot com>
+
+pkgname=i3status-rust-full-git
+pkgver=0.30.0.r2998.g05b44ce1
+pkgrel=1
+pkgdesc='Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust'
+arch=('x86_64')
+url='https://github.com/greshake/i3status-rust'
+license=('GPL3')
+depends=('libpulse' 'lm_sensors' 'notmuch')
+makedepends=('git' 'rust')
+optdepends=('alsa-utils: for the volume block'
+ 'bluez: for the bluetooth block'
+ 'fakeroot: for the pacman block to show pending updates'
+ 'kdeconnect: for the kdeconnect block'
+ 'powerline-fonts: for all themes using the powerline arrow char'
+ 'pulseaudio: for the volume block'
+ 'speedtest-cli: for the speedtest block'
+ 'ttf-font-awesome: for the awesome icons'
+ 'upower: for the battery block')
+provides=("${pkgname%-full-*}")
+conflicts=("${pkgname%-full-*}")
+install="${pkgname%-full-*}.install"
+source=("${pkgname%-*}::git+$url")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).r$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd "${pkgname%-*}"
+ cargo build --release --all-features
+}
+
+package() {
+ cd "${pkgname%-*}"
+ install -Dm755 target/release/i3status-rs "$pkgdir/usr/bin/i3status-rs"
+ install -Dm644 man/i3status-rs.1 -t "$pkgdir/usr/share/man/man1"
+
+ for icon_set in files/icons/*.toml; do
+ install -Dm644 "$icon_set" -t "$pkgdir/usr/share/${pkgname%-*}/icons"
+ done
+
+ for theme in files/themes/*.toml; do
+ install -Dm644 "$theme" -t "$pkgdir/usr/share/${pkgname%-*}/themes"
+ done
+
+ for example_config in examples/*.toml; do
+ install -Dm644 "$example_config" -t "$pkgdir/usr/share/doc/${pkgname%-*}/examples"
+ done
+}
diff --git a/i3status-rust.install b/i3status-rust.install
new file mode 100644
index 000000000000..f747145f966a
--- /dev/null
+++ b/i3status-rust.install
@@ -0,0 +1,9 @@
+post_install() {
+echo ""
+echo "==> Copy example config file to .config dir:"
+echo "$ cp /usr/share/doc/i3status-rust/examples/example_config.toml ~/.config/i3/config.toml"
+echo ""
+echo "==> And edit bar section of the i3 config file."
+echo "status_command i3status-rs ~/.config/i3/config.toml"
+echo ""
+}