summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Uhl2020-09-08 16:41:33 +0200
committerPhilipp Uhl2020-09-08 16:41:33 +0200
commit6f668a9874405d719ba78b57281297293902ee5c (patch)
treeda7fb9be1634056199ceaa375ff18ae44485d36e
downloadaur-6f668a9874405d719ba78b57281297293902ee5c.tar.gz
Adds initial PKGBUILD and SRCINFO
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64565e828fef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = bspwm-rounded-corners-git
+ pkgdesc = A tiling window manager based on binary space partitioning with rounded corners
+ pkgver = 0.9.10.r12.g98e9642
+ pkgrel = 1
+ url = https://github.com/phuhl/bspwm-rounded
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ depends = bash
+ depends = xcb-util
+ depends = xcb-util-wm
+ depends = xcb-util-keysyms
+ optdepends = sxhkd-git: to define keyboard and pointer bindings
+ optdepends = bar-aint-recursive: for the example panel
+ optdepends = xtitle-git: for the example panel
+ optdepends = sutils-git: for the example panel
+ optdepends = terminus-font: for the example panel
+ optdepends = python3: for some scripting examples
+ provides = bspwm
+ conflicts = bspwm
+ source = bspwm-rounded-corners-git::git://github.com/phuhl/bspwm-rounded.git#branch=master
+ md5sums = SKIP
+
+pkgname = bspwm-rounded-corners-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaff66656234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Philipp Uhl <git@ph-uhl.com>
+
+pkgname=bspwm-rounded-corners-git
+pkgver=0.9.10.r12.g98e9642
+pkgrel=1
+pkgdesc="A tiling window manager based on binary space partitioning with rounded corners"
+url="https://github.com/phuhl/bspwm-rounded"
+arch=('x86_64')
+license=('custom:BSD')
+depends=('bash' 'xcb-util' 'xcb-util-wm' 'xcb-util-keysyms')
+makedepends=('git')
+optdepends=('sxhkd-git: to define keyboard and pointer bindings'
+ 'bar-aint-recursive: for the example panel'
+ 'xtitle-git: for the example panel'
+ 'sutils-git: for the example panel'
+ 'terminus-font: for the example panel'
+ 'python3: for some scripting examples')
+source=("$pkgname::git://github.com/phuhl/bspwm-rounded.git#branch=master")
+md5sums=('SKIP')
+provides=("bspwm")
+conflicts=("bspwm")
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}