summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGunar C. Gessner2017-03-15 14:34:23 -0300
committerGunar C. Gessner2017-03-15 14:36:17 -0300
commit6f8c34cb5eb8096e481d61b69164fddab2a02b2c (patch)
tree9a30cf7e20c58da983513c65d451c92c4859b27f
parent757329ce00fb7294bbd2e95d665c0c0891150821 (diff)
downloadaur-6f8c34cb5eb8096e481d61b69164fddab2a02b2c.tar.gz
reactivate package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 39 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1334a1f7d722..888f3eed336c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = reredirect-git
pkgdesc = Tool to dynamicly redirect outputs of a running process
- pkgver = v0.1.r5.ga80845a
+ pkgver = 146
pkgrel = 1
- url = https://github.com/jerome-pouiller/reredirect/
+ url = https://github.com/jerome-pouiller/reredirect
arch = i686
arch = x86_64
- license = custom
- source = reredirect::git+git://github.com/jerome-pouiller/reredirect.git
- sha1sums = SKIP
+ license = MIT
+ makedepends = git
+ depends = glibc
+ provides = reredirect
+ conflicts = reredirect
+ source = reredirect-git::git+http://github.com/jerome-pouiller/reredirect.git
+ md5sums = SKIP
pkgname = reredirect-git
diff --git a/PKGBUILD b/PKGBUILD
index d14116f15960..e83845ae1a3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
-# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
-
-_pkgname=reredirect
-pkgname=${_pkgname}-git
-pkgver=v0.1.r5.ga80845a
+# Maintainer: Gunar C. Gessner <me@gunargessner.com>
+_pkgname="reredirect"
+pkgname="${_pkgname}-git"
+pkgver=146
pkgrel=1
pkgdesc="Tool to dynamicly redirect outputs of a running process"
-arch=(i686 x86_64)
-url="https://github.com/jerome-pouiller/${_pkgname}/"
-license=('custom')
-source=("${_pkgname}::git+git://github.com/jerome-pouiller/${_pkgname}.git")
-sha1sums=('SKIP')
+arch=("i686" "x86_64")
+url="https://github.com/jerome-pouiller/reredirect"
+license=('MIT')
+groups=()
+depends=('glibc')
+makedepends=('git')
+optdepends=()
+provides=('reredirect')
+conflicts=('reredirect')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+http://github.com/jerome-pouiller/${pkgname}.git")
+noextract=()
+md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$srcdir/$pkgname"
+ git rev-list --count HEAD
}
-
+
build() {
- cd "$srcdir/${_pkgname}"
+ cd "$pkgname"
make
}
-
+
package() {
- cd "$srcdir/${_pkgname}"
- make PREFIX=/usr DESTDIR=${pkgdir} install
-} \ No newline at end of file
+ cd "$pkgname"
+ install -D -m 644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}