summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:04:08 +0200
committerMaxime Gauduin2015-06-09 12:04:08 +0200
commit6fcf098b3e97873ef735e1c66eff62b0422560d3 (patch)
tree42b671a59a63972a7240629b56bfb7bc073cfbc7
downloadaur-6fcf098b3e97873ef735e1c66eff62b0422560d3.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD44
-rw-r--r--midori.install14
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f675da6d899e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = midori-granite
+ pkgdesc = A lightweight, fast, and free web browser
+ pkgver = 0.5.10
+ pkgrel = 1
+ url = http://midori-browser.org/
+ install = midori.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = LGPL2.1
+ makedepends = cmake
+ makedepends = intltool
+ makedepends = librsvg
+ makedepends = ninja
+ makedepends = vala
+ depends = gcr
+ depends = granite
+ depends = libnotify
+ depends = libxss
+ depends = libzeitgeist
+ depends = webkitgtk
+ optdepends = aria2: Download utility
+ optdepends = gst-plugins-base: HTML5 OGG videos support
+ optdepends = gst-plugins-good: HTML5 H264 and WebM videos support
+ optdepends = gst-libav: HTML5 H264 videos support
+ provides = midori
+ conflicts = midori
+ options = !emptydirs
+ source = http://midori-browser.org/downloads/midori_0.5.10_all_.tar.bz2
+ sha256sums = 702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f
+
+pkgname = midori-granite
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..a0e5facd3cfb
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=('midori-granite')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..601f27436fb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=midori-granite
+pkgver=0.5.10
+pkgrel=1
+pkgdesc='A lightweight, fast, and free web browser'
+arch=('i686' 'x86_64')
+url='http://midori-browser.org/'
+license=('LGPL2.1')
+groups=('pantheon')
+depends=('gcr' 'granite' 'libnotify' 'libxss' 'libzeitgeist' 'webkitgtk')
+makedepends=('cmake' 'intltool' 'librsvg' 'ninja' 'vala')
+optdepends=('aria2: Download utility'
+ 'gst-plugins-base: HTML5 OGG videos support'
+ 'gst-plugins-good: HTML5 H264 and WebM videos support'
+ 'gst-libav: HTML5 H264 videos support')
+provides=('midori')
+conflicts=('midori')
+options=('!emptydirs')
+install='midori.install'
+source=("http://midori-browser.org/downloads/midori_${pkgver}_all_.tar.bz2")
+sha256sums=('702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f')
+
+build() {
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DUSE_GRANITE='TRUE' \
+ -DUSE_GTK3='TRUE' \
+ -G Ninja
+ ninja
+}
+
+package() {
+ cd build
+
+ DESTDIR="${pkgdir}" ninja install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/midori.install b/midori.install
new file mode 100644
index 000000000000..dc2628ff39de
--- /dev/null
+++ b/midori.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: