summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-07-18 08:27:20 +0200
committera8212023-07-18 08:27:20 +0200
commit6fe3eb22ebaf508b9f3ff264792eed15025b3760 (patch)
treeb6a4966142f853d0ae732888405a5475d7e34b96
parent045b862ade772a775337ffe9a56d49adf718b9a4 (diff)
downloadaur-6fe3eb22ebaf508b9f3ff264792eed15025b3760.tar.gz
Fix tests: remove deprecated distance metric
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6955a8a9b481..f634024cd236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pynndescent
pkgdesc = Simple fast approximate nearest neighbor search
pkgver = 0.5.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lmcinnes/pynndescent
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 7cfec99ef468..3275aec4bdb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: a821
pkgname=python-pynndescent
pkgver=0.5.10
-pkgrel=1
+pkgrel=2
pkgdesc="Simple fast approximate nearest neighbor search"
arch=('any')
url="https://github.com/lmcinnes/pynndescent"
@@ -12,6 +12,11 @@ checkdepends=('python-pytest')
source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz")
sha256sums=('5d5dc683c03ef55fe3ddf693859720ca18f85c6e6e5bb0b4f14870278d5288ad')
+prepare() {
+ # remove deprecated distance metric (removed in SciPy 1.11)
+ sed -i 's/^ \+"kulsinski",//' "pynndescent-$pkgver/pynndescent/tests/test_distances.py"
+}
+
build() {
cd "pynndescent-$pkgver"
python -m build --wheel --no-isolation