summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2023-11-12 21:50:39 +0600
committerzoorat2023-11-12 21:50:39 +0600
commit6fec14797a9b97321d771a3082a906e04ab339ed (patch)
tree09af4729b70fecaaa5a15040ab3ce00e4f6b6047
parentb4c491f0f5d59b69962133413d1374872b148484 (diff)
downloadaur-6fec14797a9b97321d771a3082a906e04ab339ed.tar.gz
sorry for the mess
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90b6c74c70d..5f726ccae142 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-spotdl
pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
pkgver = 4.2.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/spotDL/spotify-downloader
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
index f8b77578b1ca..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
*
!.gitignore
-!Makefile
!PKGBUILD
!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index bcc7a8ea06d1..9768c489e7d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-spotdl
pkgver=4.2.1
-pkgrel=3
+pkgrel=4
pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
arch=('any')
@@ -52,21 +52,18 @@ b2sums=('f07541071b20fbb1ab7f98ff9cd1543a62edd52354531bbb2d7f4d4ef508a1d3a7b80a1
# Document: https://wiki.archlinux.org/title/Python_package_guidelines
build() {
- pushd spotdl-$pkgver
+ cd spotdl-$pkgver
# https://github.com/python-poetry/poetry/issues/5547
python -m build --wheel --no-isolation
- popd
}
check() {
- pushd spotdl-$pkgver
+ cd spotdl-$pkgver
pytest || echo 'Tests failed!'
- popd
}
package() {
- pushd spotdl-$pkgver
+ cd spotdl-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- popd
}